aboutsummaryrefslogtreecommitdiff
path: root/sensor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sensor/CMakeLists.txt')
-rw-r--r--sensor/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/sensor/CMakeLists.txt b/sensor/CMakeLists.txt
index d571e38..fb118d1 100644
--- a/sensor/CMakeLists.txt
+++ b/sensor/CMakeLists.txt
@@ -5,10 +5,12 @@ add_library(trygvis-sensor
main/io.cpp
${INCLUDES})
-include_directories("${PROJECT_SOURCE_DIR}/json/src")
-include_directories(include)
-
# Boost
find_package(Boost COMPONENTS regex system REQUIRED)
+target_include_directories(trygvis-sensor
+ PUBLIC "${PROJECT_SOURCE_DIR}/json/src"
+ PUBLIC "${PROJECT_SOURCE_DIR}/sensor/include"
+ PUBLIC "${Boost_INCLUDE_DIRS}")
+
add_subdirectory(test)