summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-04-15 15:41:44 +0100
committerJoshua Lock <josh@linux.intel.com>2010-04-15 17:49:49 +0100
commit36652f51abc8e2e28b51f06386e00e491c1590a5 (patch)
tree3c2cac50cb8f772115fe6e7224c5579a670c2fcf
parentd3fbb56c2ffa44e2da15ca4bfa4def35792ab6f7 (diff)
downloadopenembedded-core-36652f51abc8e2e28b51f06386e00e491c1590a5.tar.gz
openembedded-core-36652f51abc8e2e28b51f06386e00e491c1590a5.tar.bz2
openembedded-core-36652f51abc8e2e28b51f06386e00e491c1590a5.tar.xz
openembedded-core-36652f51abc8e2e28b51f06386e00e491c1590a5.zip
qemu_git: Ensure we have the required dependencies for a native build
qemu-native requires a libGL and the SDL development headers to build with our GL "emulation". This patch adds a check before configure for the native package to ensure that the sdl.pc file and GL so files exist and bombs out otherwise. Signed-off-by: Joshua Lock <josh@linux.intel.com>
-rw-r--r--meta/packages/qemu/qemu_git.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/meta/packages/qemu/qemu_git.bb b/meta/packages/qemu/qemu_git.bb
index 98fdc7c7d..e9129649a 100644
--- a/meta/packages/qemu/qemu_git.bb
+++ b/meta/packages/qemu/qemu_git.bb
@@ -1,7 +1,7 @@
LICENSE = "GPL"
DEPENDS = "zlib"
PV = "0.10.6+git${SRCREV}"
-PR = "r2"
+PR = "r3"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
@@ -23,6 +23,23 @@ EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-sof
inherit autotools
+# For our gl powered QEMU you need libGL and SDL headers
+do_configure_prepend_virtclass-native() {
+ libgl='no'
+ libsdl='no'
+
+ test -e /usr/lib/libGL.so -a -e /usr/lib/libGLU.so && libgl='yes'
+ test -e /usr/lib64/libGL.so -a -e /usr/lib64/libGLU.so && libgl='yes'
+
+ test -e /usr/lib/pkgconfig/sdl.pc -o -e /usr/lib64/pkgconfig/sdl.pc && libsdl='yes'
+
+ if [ "$libsdl" != 'yes' -o "$libgl" != 'yes' ]; then
+ echo "You need libGL.so and libGLU.so to exist in your library path and the development headers for SDL installed to build qemu-native.
+ Ubuntu package names are: libgl1-mesa-dev, libglu1-mesa-dev and libsdl1.2-dev"
+ exit 1;
+ fi
+}
+
do_configure() {
${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
chmod a+x ${S}/target-i386/beginend_funcs.sh