summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-01-10 23:50:30 +0000
committerRichard Purdie <richard@openedhand.com>2008-01-10 23:50:30 +0000
commited8770a901f44c455d5e5edfa378819a15780d84 (patch)
tree5994be65c1f2ef039cb6d59b8d4b1e3546fea089
parent5f39e9fa0f187bd8bfe071abb7aa8048fd0befc7 (diff)
downloadopenembedded-core-ed8770a901f44c455d5e5edfa378819a15780d84.tar.gz
openembedded-core-ed8770a901f44c455d5e5edfa378819a15780d84.tar.bz2
openembedded-core-ed8770a901f44c455d5e5edfa378819a15780d84.tar.xz
openembedded-core-ed8770a901f44c455d5e5edfa378819a15780d84.zip
Add EXTRA_IMAGE_FEATURES for ease of use in local.conf
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3461 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--build/conf/local.conf.sample8
-rw-r--r--meta/conf/bitbake.conf1
2 files changed, 5 insertions, 4 deletions
diff --git a/build/conf/local.conf.sample b/build/conf/local.conf.sample
index 9cdbe59d9..5e55f9277 100644
--- a/build/conf/local.conf.sample
+++ b/build/conf/local.conf.sample
@@ -35,7 +35,7 @@ DISTRO ?= "poky"
# For bleeding edge / experimental / unstable package versions
# DISTRO ?= "poky-bleeding"
-# IMAGE_FEATURES configuration of the generated images
+# EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images
# (Some of these are automatically added to certain image types)
# "dbg-pkgs" - add -dbg packages for all installed packages
# (adds symbol information for debugging/profiling)
@@ -50,13 +50,13 @@ DISTRO ?= "poky"
# There are other application targets too, see meta/classes/poky-image.bbclass
# and meta/packages/tasks/task-poky.bb for more details.
-IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
+EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
# The default IMAGE_FEATURES above are too large for the mx31phy and
# c700/c750 machines which have limited space. The code below limits
# the default features for those machines.
-IMAGE_FEATURES_c7x0 = "tools-testapps debug-tweaks"
-IMAGE_FEATURES_mx31phy = "tools-testapps debug-tweaks"
+EXTRA_IMAGE_FEATURES_c7x0 = "tools-testapps debug-tweaks"
+EXTRA_IMAGE_FEATURES_mx31phy = "tools-testapps debug-tweaks"
# A list of packaging systems used in generated images
# The first package type listed will be used for rootfs generation
diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
index 49df8869a..75a69f6da 100644
--- a/meta/conf/bitbake.conf
+++ b/meta/conf/bitbake.conf
@@ -588,6 +588,7 @@ MACHINE_EXTRA_RDEPENDS ?= ""
MACHINE_EXTRA_RRECOMMENDS ?= ""
MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
+IMAGE_FEATURES += "${EXTRA_IMAGE_FEATURES}"
COMBINED_FEATURES = "\
${@base_both_contain("DISTRO_FEATURES", "MACHINE_FEATURES", "alsa", d)} \