summaryrefslogtreecommitdiff
path: root/bitbake-dev/lib/bb/command.py
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-07-29 14:33:14 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-07-29 14:33:14 +0100
commit64b04685b6fd029f2f70f7017bfd51d26ccb0d11 (patch)
tree5d525e2b58e5a9b27ea3096a0047770446baaf29 /bitbake-dev/lib/bb/command.py
parent231b5f67844da39949e04ae53557cea04aacffdd (diff)
downloadopenembedded-core-64b04685b6fd029f2f70f7017bfd51d26ccb0d11.tar.gz
openembedded-core-64b04685b6fd029f2f70f7017bfd51d26ccb0d11.tar.bz2
openembedded-core-64b04685b6fd029f2f70f7017bfd51d26ccb0d11.tar.xz
openembedded-core-64b04685b6fd029f2f70f7017bfd51d26ccb0d11.zip
bitbake: Add a --revisions-changed commandline option to indicate when floating srcrevs have changed
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'bitbake-dev/lib/bb/command.py')
-rw-r--r--bitbake-dev/lib/bb/command.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/bitbake-dev/lib/bb/command.py b/bitbake-dev/lib/bb/command.py
index 9226a2772..e7c3770ff 100644
--- a/bitbake-dev/lib/bb/command.py
+++ b/bitbake-dev/lib/bb/command.py
@@ -233,6 +233,14 @@ class CommandsAsync:
command.finishAsyncCommand()
parseFiles.needcache = True
+ def compareRevisions(self, command, params):
+ """
+ Parse the .bb files
+ """
+ command.cooker.compareRevisions()
+ command.finishAsyncCommand()
+ compareRevisions.needcache = True
+
#
# Events
#
@@ -251,3 +259,14 @@ class CookerCommandFailed(bb.event.Event):
def __init__(self, data, error):
bb.event.Event.__init__(self, data)
self.error = error
+
+class CookerCommandSetExitCode(bb.event.Event):
+ """
+ Set the exit code for a cooker command
+ """
+ def __init__(self, data, exitcode):
+ bb.event.Event.__init__(self, data)
+ self.exitcode = int(exitcode)
+
+
+