summaryrefslogtreecommitdiff
path: root/meta/packages/gcc
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-06 14:59:25 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-06 14:59:25 +0000
commit64e621cf18a2a5970b172187926152893ef72174 (patch)
tree2a04bc9aa28457197ed806b1c6e5370de1f628b9 /meta/packages/gcc
parent96c69763a6f096757987cdcab2426b359f330ffd (diff)
downloadopenembedded-core-64e621cf18a2a5970b172187926152893ef72174.tar.gz
openembedded-core-64e621cf18a2a5970b172187926152893ef72174.tar.bz2
openembedded-core-64e621cf18a2a5970b172187926152893ef72174.tar.xz
openembedded-core-64e621cf18a2a5970b172187926152893ef72174.zip
gcc: remove precompiled c++ headers as they take lot of space and are not required
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3969 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-package.inc3
-rw-r--r--meta/packages/gcc/gcc_4.2.2.bb2
2 files changed, 4 insertions, 1 deletions
diff --git a/meta/packages/gcc/gcc-package.inc b/meta/packages/gcc/gcc-package.inc
index 011c4fab6..0140126ba 100644
--- a/meta/packages/gcc/gcc-package.inc
+++ b/meta/packages/gcc/gcc-package.inc
@@ -126,6 +126,9 @@ do_install () {
ln -sf gcc cc
ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${base_libdir}/cpp
ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${bindir}/cpp
+
+ # Remove precompiled c++ headers as they are really big
+ rm -rf ${D}${includedir}/c++/${BINV}/${TARGET_SYS}/bits/*.gch
}
# The gcc package contains symlinks that trip up insane
diff --git a/meta/packages/gcc/gcc_4.2.2.bb b/meta/packages/gcc/gcc_4.2.2.bb
index 0a0e9cdd1..d322de129 100644
--- a/meta/packages/gcc/gcc_4.2.2.bb
+++ b/meta/packages/gcc/gcc_4.2.2.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "The GNU cc and gcc C compilers."
HOMEPAGE = "http://www.gnu.org/software/gcc/"
SECTION = "devel"
LICENSE = "GPL"
-PR = "r6"
+PR = "r7"
inherit autotools gettext