summaryrefslogtreecommitdiff
path: root/meta/packages/matchbox-sato
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-07-05 13:30:44 +0000
committerRoss Burton <ross@openedhand.com>2007-07-05 13:30:44 +0000
commit09324bfcc9613a1bdb30382063ae9808fcb6936f (patch)
treeaef0b9f11af9167a0c80795ddbff0d1b0f74e307 /meta/packages/matchbox-sato
parentfcbafc8486106ac6c5dbf752a91afc5921c8541f (diff)
downloadopenembedded-core-09324bfcc9613a1bdb30382063ae9808fcb6936f.tar.gz
openembedded-core-09324bfcc9613a1bdb30382063ae9808fcb6936f.tar.bz2
openembedded-core-09324bfcc9613a1bdb30382063ae9808fcb6936f.tar.xz
openembedded-core-09324bfcc9613a1bdb30382063ae9808fcb6936f.zip
Don't depend on matchbox-common, but matchbox-desktop-sato. Also ship /usr/bin/matchbox-session here
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2112 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-sato')
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato/matchbox-session24
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato_0.1.bb9
2 files changed, 30 insertions, 3 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-sato/matchbox-session b/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
new file mode 100644
index 000000000..65f1ce72c
--- /dev/null
+++ b/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Very simple session manager for matchbox tools
+#
+
+# Uncomment below to enable parsing of debian menu entrys
+# export MB_USE_DEB_MENUS=1
+
+if [ -e $HOME/.matchbox/session ]
+then
+exec $HOME/.matchbox/session
+fi
+
+if [ -e /etc/matchbox/session ]
+then
+exec /etc/matchbox/session
+fi
+
+# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
+# dont exist.
+
+matchbox-desktop &
+matchbox-panel --orientation south &
+exec matchbox-window-manager $@
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
index ff9144f6a..dd03539f2 100644
--- a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
+++ b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -1,13 +1,16 @@
DESCRIPTION = "Custom MB session files for poky"
LICENSE = "GPL"
SECTION = "x11"
-RDEPENDS = "matchbox-common matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2"
-PR = "r13"
+RDEPENDS = "matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato"
+RCONFLICTS = "matchbox-common"
+PR = "r14"
-SRC_URI = "file://etc"
+SRC_URI = "file://etc file://matchbox-session"
S = ${WORKDIR}
do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/matchbox-session ${D}/${bindir}
cp -R ${S}/etc ${D}/etc
rm -fR ${D}/etc/.svn
rm -fR ${D}/etc/matchbox/.svn