summaryrefslogtreecommitdiff
path: root/meta/recipes-graphics/mesa/mesa-dri
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-20 23:10:12 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-22 11:48:37 +0100
commit1a55faf994b30101026b6c8980023f213ee1db2c (patch)
tree2c76c02b48984b263120944fe0ac8a713cc0cd31 /meta/recipes-graphics/mesa/mesa-dri
parent92e97ab066f58f38d3cc74c984ad4c7abc7d51b1 (diff)
downloadopenembedded-core-1a55faf994b30101026b6c8980023f213ee1db2c.tar.gz
openembedded-core-1a55faf994b30101026b6c8980023f213ee1db2c.tar.bz2
openembedded-core-1a55faf994b30101026b6c8980023f213ee1db2c.tar.xz
openembedded-core-1a55faf994b30101026b6c8980023f213ee1db2c.zip
mesa-xlib, mesa-dri: Probe for newlocale() before using it.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri/uclibc.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri/uclibc.patch b/meta/recipes-graphics/mesa/mesa-dri/uclibc.patch
new file mode 100644
index 000000000..bb5af44a3
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri/uclibc.patch
@@ -0,0 +1,40 @@
+Index: Mesa-7.10.2/src/mesa/main/imports.c
+===================================================================
+--- Mesa-7.10.2.orig/src/mesa/main/imports.c 2011-03-01 12:57:29.000000000 -0800
++++ Mesa-7.10.2/src/mesa/main/imports.c 2011-07-20 19:08:49.441785510 -0700
+@@ -757,7 +757,7 @@
+ float
+ _mesa_strtof( const char *s, char **end )
+ {
+-#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__)
++#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && defined (HAVE_NEWLOCALE)
+ static locale_t loc = NULL;
+ if (!loc) {
+ loc = newlocale(LC_CTYPE_MASK, "C", NULL);
+Index: Mesa-7.10.2/src/glsl/strtod.c
+===================================================================
+--- Mesa-7.10.2.orig/src/glsl/strtod.c 2011-01-03 16:45:51.000000000 -0800
++++ Mesa-7.10.2/src/glsl/strtod.c 2011-07-20 19:10:21.441785488 -0700
+@@ -44,7 +44,7 @@
+ double
+ glsl_strtod(const char *s, char **end)
+ {
+-#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__)
++#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && defined (HAVE_NEWLOCALE)
+ static locale_t loc = NULL;
+ if (!loc) {
+ loc = newlocale(LC_CTYPE_MASK, "C", NULL);
+Index: Mesa-7.10.2/configure.ac
+===================================================================
+--- Mesa-7.10.2.orig/configure.ac 2011-07-20 19:09:02.000000000 -0700
++++ Mesa-7.10.2/configure.ac 2011-07-20 19:09:57.121785492 -0700
+@@ -450,6 +450,9 @@
+ dnl See if posix_memalign is available
+ AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])
+
++dnl See if newlocale is available
++AC_CHECK_FUNCS_ONCE(newlocale)
++
+ dnl SELinux awareness.
+ AC_ARG_ENABLE([selinux],
+ [AS_HELP_STRING([--enable-selinux],