summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/lttng/lttng-viewer
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-05-03 21:54:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-05 11:54:43 +0100
commit6252898534a885237a3df9c8cb4ea1fdd43f65c5 (patch)
treefbcf7441f05e66c128bd0041dd46c8eaba1acf65 /meta/recipes-kernel/lttng/lttng-viewer
parent50a54e885e3ec1c889f754fa3f5dce0072cfb6c9 (diff)
downloadopenembedded-core-6252898534a885237a3df9c8cb4ea1fdd43f65c5.tar.gz
openembedded-core-6252898534a885237a3df9c8cb4ea1fdd43f65c5.tar.bz2
openembedded-core-6252898534a885237a3df9c8cb4ea1fdd43f65c5.tar.xz
openembedded-core-6252898534a885237a3df9c8cb4ea1fdd43f65c5.zip
lttng-viewer: explicitly add linkage to lttvwindow
Fixes [YOCTO #412] Also update FILES_${PN}. Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-viewer')
-rw-r--r--meta/recipes-kernel/lttng/lttng-viewer/add_linkage_to_lttvwindow.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-viewer/add_linkage_to_lttvwindow.patch b/meta/recipes-kernel/lttng/lttng-viewer/add_linkage_to_lttvwindow.patch
new file mode 100644
index 000000000..4a135dff2
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-viewer/add_linkage_to_lttvwindow.patch
@@ -0,0 +1,42 @@
+Upstream-Status: Inappropriate [configuration]
+
+Explicitly add linkage to lttvwindow.
+
+Without the fix, lttv-gui inside target can't run, complaining
+"undefined symbol: LTTV_VIEWER_CONSTRUCTORS".
+
+Tue May 3 21:39:37 CST 2011
+
+Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
+
+diff --git a/lttv/modules/gui/common.am b/lttv/modules/gui/common.am
+index ce50113..89083aa 100644
+--- a/lttv/modules/gui/common.am
++++ b/lttv/modules/gui/common.am
+@@ -21,3 +21,4 @@ AM_LDFLAGS = $(MODULE_LDFLAGS)
+
+ libdir = ${lttvplugindir}
+
++LIBS += $(GTK_LIBS) -L${top_builddir}/lttv/modules/gui/lttvwindow/lttvwindow -llttvwindow
+diff --git a/lttv/modules/gui/lttvwindow/lttvwindow/Makefile.am b/lttv/modules/gui/lttvwindow/lttvwindow/Makefile.am
+index c953fc9..489d640 100644
+--- a/lttv/modules/gui/lttvwindow/lttvwindow/Makefile.am
++++ b/lttv/modules/gui/lttvwindow/lttvwindow/Makefile.am
+@@ -1,13 +1,14 @@
+ ## Process this file with automake to produce Makefile.in
+
+-include ../../common.am
+-
+ INCLUDES = \
+ -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
+ -DPACKAGE_LOCALE_DIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+ $(DEFAULT_INCLUDES)
+
+-#libdir = ${lttvplugindir}
++AM_CFLAGS = $(MODULE_CFLAGS)
++AM_LDFLAGS = $(MODULE_LDFLAGS)
++
++libdir = ${lttvplugindir}
+
+ lib_LTLIBRARIES = liblttvwindow.la
+