summaryrefslogtreecommitdiff
path: root/meta/recipes-multimedia/pulseaudio/libcanberra
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta/recipes-multimedia/pulseaudio/libcanberra
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadopenembedded-core-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
openembedded-core-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.bz2
openembedded-core-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.xz
openembedded-core-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.zip
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/pulseaudio/libcanberra')
-rw-r--r--meta/recipes-multimedia/pulseaudio/libcanberra/autoconf_version.patch38
-rw-r--r--meta/recipes-multimedia/pulseaudio/libcanberra/nofallbackfix.patch16
2 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/pulseaudio/libcanberra/autoconf_version.patch b/meta/recipes-multimedia/pulseaudio/libcanberra/autoconf_version.patch
new file mode 100644
index 000000000..73a2ea6e4
--- /dev/null
+++ b/meta/recipes-multimedia/pulseaudio/libcanberra/autoconf_version.patch
@@ -0,0 +1,38 @@
+Allow a slightly older autoconf and disable the inbuild libltdl
+
+RP - 16/4/09
+
+Index: libcanberra-0.10/Makefile.am
+===================================================================
+--- libcanberra-0.10.orig/Makefile.am 2009-04-16 14:38:53.000000000 +0100
++++ libcanberra-0.10/Makefile.am 2009-04-16 14:39:04.000000000 +0100
+@@ -19,7 +19,7 @@
+ dist_doc_DATA = README
+
+ EXTRA_DIST = bootstrap.sh autogen.sh LGPL libcanberra.schemas
+-SUBDIRS = src gtkdoc libltdl doc
++SUBDIRS = src gtkdoc doc
+
+ MAINTAINERCLEANFILES = README
+ noinst_DATA = README
+Index: libcanberra-0.10/configure.ac
+===================================================================
+--- libcanberra-0.10.orig/configure.ac 2009-04-16 14:32:33.000000000 +0100
++++ libcanberra-0.10/configure.ac 2009-04-16 14:37:50.000000000 +0100
+@@ -19,7 +19,7 @@
+ # License along with libcanberra. If not, see
+ # <http://www.gnu.org/licenses/>.
+
+-AC_PREREQ(2.62)
++AC_PREREQ(2.61)
+
+ AC_INIT([libcanberra], 0.10, [mzyvopnaoreen (at) 0pointer (dot) de])
+ AC_CONFIG_SRCDIR([src/common.c])
+@@ -70,7 +70,6 @@
+ AC_PROG_LIBTOOL
+ AC_SUBST(LTDLINCL)
+ AC_SUBST(LIBLTDL)
+-AC_CONFIG_SUBDIRS(libltdl)
+
+ #### Determine build environment ####
+
diff --git a/meta/recipes-multimedia/pulseaudio/libcanberra/nofallbackfix.patch b/meta/recipes-multimedia/pulseaudio/libcanberra/nofallbackfix.patch
new file mode 100644
index 000000000..89a4fbf9f
--- /dev/null
+++ b/meta/recipes-multimedia/pulseaudio/libcanberra/nofallbackfix.patch
@@ -0,0 +1,16 @@
+Index: libcanberra-0.10/src/sound-theme-spec.c
+===================================================================
+--- libcanberra-0.10.orig/src/sound-theme-spec.c 2009-05-22 17:08:23.000000000 +0100
++++ libcanberra-0.10/src/sound-theme-spec.c 2009-05-22 17:12:50.000000000 +0100
+@@ -398,9 +398,9 @@
+ if ((ret = load_theme_dir(t, name)) < 0)
+ goto fail;
+
++ /* The fallback theme may intentionally not exist so ignore failure */
+ if (!t->loaded_fallback_theme)
+- if ((ret = load_theme_dir(t, FALLBACK_THEME)) < 0)
+- goto fail;
++ load_theme_dir(t, FALLBACK_THEME);
+
+ if (*_t)
+ ca_theme_data_free(*_t);