summaryrefslogtreecommitdiff
path: root/meta/recipes-sato/pimlico/dates
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-18 15:55:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-20 15:25:01 +0100
commit0387faee9cf869fd8b9f9e1f5b7a5e23bd37e97e (patch)
tree4a37b922de4ecdd1c60eb549811becc47381b1da /meta/recipes-sato/pimlico/dates
parent2c0dab3fc508b4b80a61b8ce0f6292ba66ad86d3 (diff)
downloadopenembedded-core-0387faee9cf869fd8b9f9e1f5b7a5e23bd37e97e.tar.gz
openembedded-core-0387faee9cf869fd8b9f9e1f5b7a5e23bd37e97e.tar.bz2
openembedded-core-0387faee9cf869fd8b9f9e1f5b7a5e23bd37e97e.tar.xz
openembedded-core-0387faee9cf869fd8b9f9e1f5b7a5e23bd37e97e.zip
pimlico/dates: Fix build on uclibc
uclibc does not have NL_TIME_FIRST_WEEKDAY Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-sato/pimlico/dates')
-rw-r--r--meta/recipes-sato/pimlico/dates/uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-sato/pimlico/dates/uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch b/meta/recipes-sato/pimlico/dates/uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch
new file mode 100644
index 000000000..6ade4708f
--- /dev/null
+++ b/meta/recipes-sato/pimlico/dates/uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch
@@ -0,0 +1,37 @@
+uclibc has langinfo.h but it does not define _NL_TIME_FIRST_WEEKDAY
+therefore we introduce a check in configure for the this define
+and then we make sure that we use it when it really exists
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2011-07-18 10:34:15.000000000 -0700
++++ git/configure.ac 2011-07-18 10:54:26.403798188 -0700
+@@ -98,6 +98,8 @@
+ src/libgtkdatesview.pc
+ ])
+
++AC_CHECK_DECLS([_NL_TIME_FIRST_WEEKDAY],[],[],[[#include <langinfo.h>]])
++
+ AC_OUTPUT
+
+ echo " "
+Index: git/src/dates_view.c
+===================================================================
+--- git.orig/src/dates_view.c 2011-07-18 10:34:15.000000000 -0700
++++ git/src/dates_view.c 2011-07-18 10:58:46.093798136 -0700
+@@ -1505,7 +1505,11 @@
+ priv->days = 1;
+ priv->months = 0;
+ priv->months_in_row = 4;
++#if HAVE_DECL__NL_TIME_FIRST_WEEKDAY
+ priv->week_start = *nl_langinfo (_NL_TIME_FIRST_WEEKDAY) - 1;
++#else
++ priv->week_start = 0;
++#endif
+ priv->dragbox = TRUE;
+ priv->single_click = TRUE;
+ priv->double_click = FALSE;