summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-27 13:21:00 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-27 13:21:00 +0000
commit82f775c3d80c91919e36c434377a8e48eda96b5e (patch)
tree2d1987d3685a35698c8135d97a8aed93e9f18812 /meta
parent9479bd52c519d1390073bf381b67a3f5fa336953 (diff)
downloadopenembedded-core-82f775c3d80c91919e36c434377a8e48eda96b5e.tar.gz
openembedded-core-82f775c3d80c91919e36c434377a8e48eda96b5e.tar.bz2
openembedded-core-82f775c3d80c91919e36c434377a8e48eda96b5e.tar.xz
openembedded-core-82f775c3d80c91919e36c434377a8e48eda96b5e.zip
diffutils: added 2.8.1 for SDK (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1568 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/diffutils/diffutils_2.8.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/packages/diffutils/diffutils_2.8.1.bb b/meta/packages/diffutils/diffutils_2.8.1.bb
new file mode 100644
index 000000000..a0a7b7dad
--- /dev/null
+++ b/meta/packages/diffutils/diffutils_2.8.1.bb
@@ -0,0 +1,25 @@
+SECTION = "base"
+LICENSE = "GPL"
+DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
+sdiff, and cmp utilities. These programs are usually \
+used for creating patch files."
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+# diffutils assumes non-glibc compilation with uclibc and
+# this causes it to generate its own implementations of
+# standard functionality. regex.c actually breaks compilation
+# because it uses __mempcpy, there are other things (TBD:
+# see diffutils.mk in buildroot)
+EXTRA_OECONF_linux-uclibc = "--without-included-regex"
+
+do_install_append () {
+ mv ${D}${bindir}/diff ${D}${bindir}/diff.${PN}
+}
+
+ALTERNATIVE_NAME = "diff"
+ALTERNATIVE_PATH = "diff.${PN}"
+ALTERNATIVE_PRIORITY = "100"