summaryrefslogtreecommitdiff
path: root/openembedded/packages/avahi
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
commit95efeafc86f47592b37c44f2f7314324cc04250d (patch)
treee60fe38e88d8e6cf42cf1311c5ada752b79a59c7 /openembedded/packages/avahi
parent7755d9d194b42ea859096f805f2e22ae5b6e6281 (diff)
downloadopenembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.gz
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.bz2
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.xz
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.zip
Add gtk+, avahi, dbus-0.34 (.36 coming soon) and dependencies. Fix x11-common breakage.
git-svn-id: https://svn.o-hand.com/repos/poky@13 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/avahi')
-rw-r--r--openembedded/packages/avahi/avahi_0.2.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/openembedded/packages/avahi/avahi_0.2.bb b/openembedded/packages/avahi/avahi_0.2.bb
new file mode 100644
index 000000000..00c4dbd59
--- /dev/null
+++ b/openembedded/packages/avahi/avahi_0.2.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
+HOMEPAGE = "http://www.freedesktop.org/Software/Avahi"
+LICENCE= "GPL"
+DEPENDS = "expat libdaemon dbus-0.34"
+RRECOMMENDS = "libnss-mdns"
+SECTION = "net"
+PRIORITY = "optional"
+
+SRC_URI = "http://www.freedesktop.org/~lennart/avahi-${PV}.tar.gz"
+
+# file://no-strict-ansi.patch;patch=1"
+
+PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc"
+
+FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
+FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
+FILES_avahi-daemon = "${sbindir}/avahi-daemon \
+ ${sysconfdir}/avahi/avahi-daemon.conf \
+ ${sysconfdir}/avahi/services \
+ ${sysconfdir}/dbus-1 \
+ ${sysconfdir}/init.d/avahi-daemon \
+ ${datadir}/avahi/introspection/*.introspect \
+ ${datadir}/avahi/avahi-service.dtd"
+FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
+FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
+ ${sysconfdir}/avahi/avahi-dnsconfd.action \
+ ${sysconfdir}/init.d/avahi-dnsconfd"
+FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
+
+CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
+
+EXTRA_OECONF = "--with-distro=debian --disable-gtk --disable-python"
+inherit autotools
+inherit update-rc.d
+
+INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
+INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
+INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
+
+pkg_postinst_avahi-daemon () {
+ grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon avahi
+}
+
+pkg_postrm_avahi-daemon () {
+ deluser avahi || true
+}
+