summaryrefslogtreecommitdiff
path: root/openembedded/packages/vera-fonts
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 18:07:55 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 18:07:55 +0000
commit9ed0d2aa99a76a864d4793f54146c0e79e373712 (patch)
treebf6b07b0cfcc23ebb23130013e348ff84f38ce32 /openembedded/packages/vera-fonts
parent047f13b69a6907483a4cf71cf20c8434e20c8873 (diff)
downloadopenembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.tar.gz
openembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.tar.bz2
openembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.tar.xz
openembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.zip
Add some extra packages to the image
git-svn-id: https://svn.o-hand.com/repos/poky@10 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/vera-fonts')
-rw-r--r--openembedded/packages/vera-fonts/ttf-bitstream-vera_1.10.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/openembedded/packages/vera-fonts/ttf-bitstream-vera_1.10.bb b/openembedded/packages/vera-fonts/ttf-bitstream-vera_1.10.bb
new file mode 100644
index 000000000..b756c99e4
--- /dev/null
+++ b/openembedded/packages/vera-fonts/ttf-bitstream-vera_1.10.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "The Bitstream Vera fonts - TTF Edition"
+SECTION = "x11/fonts"
+PRIORITY = "optional"
+LICENSE = "Bitstream Vera"
+PACKAGE_ARCH = "all"
+PR = "r3"
+RDEPENDS = "libfontconfig-utils"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
+
+do_install () {
+ install -d ${D}${prefix}/share/fonts/ttf/
+ for i in *.ttf; do
+ install -m 644 $i ${D}${prefix}/share/fonts/ttf/${i}
+ done
+
+ # fontconfig ships this too. not sure what to do about it.
+ #install -d ${D}${sysconfdir}/fonts
+ #install -m 644 local.conf ${D}${sysconfdir}/fonts/local.conf
+
+
+ install -d ${D}${prefix}/share/doc/${PN}/
+ for i in *.TXT; do
+ install -m 644 $i ${D}${prefix}/share/doc/${PN}/$i
+ done
+}
+
+pkg_postinst () {
+#!/bin/sh
+fc-cache
+}
+
+
+FILES_${PN} = "/etc ${datadir}/fonts"