summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/rsync/rsync-2.6.9/rsyncd.conf15
-rw-r--r--meta/packages/rsync/rsync_2.6.9.bb23
2 files changed, 36 insertions, 2 deletions
diff --git a/meta/packages/rsync/rsync-2.6.9/rsyncd.conf b/meta/packages/rsync/rsync-2.6.9/rsyncd.conf
new file mode 100644
index 000000000..845f5b33f
--- /dev/null
+++ b/meta/packages/rsync/rsync-2.6.9/rsyncd.conf
@@ -0,0 +1,15 @@
+# /etc/rsyncd.conf
+
+# Minimal configuration file for rsync daemon
+# See rsync(1) and rsyncd.conf(5) man pages for help
+
+# This file is required by rsync --daemon
+pid file = /var/run/rsyncd.pid
+use chroot = yes
+read only = yes
+
+# Simple example for enabling your own local rsync server
+#[everything]
+# path = /
+# comment = Everything except /etc exposed
+# exclude = /etc
diff --git a/meta/packages/rsync/rsync_2.6.9.bb b/meta/packages/rsync/rsync_2.6.9.bb
index a9b5c86d8..43379829e 100644
--- a/meta/packages/rsync/rsync_2.6.9.bb
+++ b/meta/packages/rsync/rsync_2.6.9.bb
@@ -1,6 +1,25 @@
-require rsync.inc
+DESCRIPTION = "A file-synchronization tool"
+HOMEPAGE = "http://rsync.samba.org/"
+BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
+SECTION = "console/network"
+PRIORITY = "optional"
+
+# needs to add acl and attr
+DEPENDS = "popt"
+
+SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz \
+ file://rsyncd.conf"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/etc
+ install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
+}
+
+EXTRA_OEMAKE='STRIP=""'
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=6d5a9d4c4d3af25cd68fd83e8a8cb09c"
-PR = "r1"
+PR = "r2"