summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/git/git-native_1.5.2.3.bb3
-rw-r--r--meta/packages/git/git.inc15
2 files changed, 18 insertions, 0 deletions
diff --git a/meta/packages/git/git-native_1.5.2.3.bb b/meta/packages/git/git-native_1.5.2.3.bb
new file mode 100644
index 000000000..f91fd03ab
--- /dev/null
+++ b/meta/packages/git/git-native_1.5.2.3.bb
@@ -0,0 +1,3 @@
+require git.inc
+inherit native
+DEPENDS = "openssl-native curl-native"
diff --git a/meta/packages/git/git.inc b/meta/packages/git/git.inc
new file mode 100644
index 000000000..384dfaaee
--- /dev/null
+++ b/meta/packages/git/git.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
+S = "${WORKDIR}/git-${PV}"
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+
+FILES_${PN} += "${datadir}/git-core"
+