summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/pth/pth_2.0.7.bb15
1 files changed, 1 insertions, 14 deletions
diff --git a/meta/packages/pth/pth_2.0.7.bb b/meta/packages/pth/pth_2.0.7.bb
index ac93a27eb..1871b2bb3 100644
--- a/meta/packages/pth/pth_2.0.7.bb
+++ b/meta/packages/pth/pth_2.0.7.bb
@@ -8,25 +8,12 @@ SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz"
PARALLEL_MAKE=""
-inherit autotools binconfig
+inherit autotools_stage binconfig
do_configure() {
gnu-configize
oe_runconf
}
-do_stage() {
- oe_libinstall -so libpth ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/
- for X in pth.h
- do
- install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
- done
-
- install -d ${STAGING_DATADIR}/aclocal
- install pth.m4 ${STAGING_DATADIR}/aclocal/
-}
-
FILES_${PN} = "${libdir}/libpth.so.*"
FILES_${PN}-dev += "${bindir}/pth-config"