summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/conf/distro/include/poky-default-revisions.inc2
-rw-r--r--meta/packages/eds/eds-dbus/optional_imapx_provider.patch62
-rw-r--r--meta/packages/eds/eds-dbus_git.bb10
3 files changed, 70 insertions, 4 deletions
diff --git a/meta/conf/distro/include/poky-default-revisions.inc b/meta/conf/distro/include/poky-default-revisions.inc
index e69979258..4c380d659 100644
--- a/meta/conf/distro/include/poky-default-revisions.inc
+++ b/meta/conf/distro/include/poky-default-revisions.inc
@@ -30,7 +30,7 @@ SRCREV_pn-contacts ??= "19853893fdb595de6aa59db0d9dc2f9451ed2933"
SRCREV_pn-dates ??= "514185dc1f6588085fda41eb59898b93d0487dd4"
SRCREV_pn-dbus-wait ??= "402"
SRCREV_pn-dri2proto ??= "66c56ab10d917e3f47f93178d7eac6430970d3c4"
-SRCREV_pn-eds-dbus ??= "ed729af002b935f7ab8542f4177919859dfc22c2"
+SRCREV_pn-eds-dbus ??= "7337d11aed576e7caaa12b4e881ad8d33668799f"
SRCREV_pn-eee-acpi-scripts ??= "df785afdacedf869b20fb88a793c13b539819270"
SRCREV_pn-exmap-console ??= "405"
SRCREV_pn-fstests ??= "266"
diff --git a/meta/packages/eds/eds-dbus/optional_imapx_provider.patch b/meta/packages/eds/eds-dbus/optional_imapx_provider.patch
new file mode 100644
index 000000000..128307a5f
--- /dev/null
+++ b/meta/packages/eds/eds-dbus/optional_imapx_provider.patch
@@ -0,0 +1,62 @@
+Index: git/camel/providers/Makefile.am
+===================================================================
+--- git.orig/camel/providers/Makefile.am 2010-07-06 18:49:34.000000000 +0800
++++ git/camel/providers/Makefile.am 2010-07-08 17:23:56.000000000 +0800
+@@ -6,6 +6,10 @@
+ IMAP4_DIR=imap4
+ endif
+
++if ENABLE_IMAPX
++IMAPX_DIR=imapx
++endif
++
+ if ENABLE_HULA
+ HULA_DIR=hula
+ endif
+@@ -15,6 +19,6 @@
+ SENDMAIL_DIR=sendmail
+ endif
+
+-SUBDIRS = pop3 $(SENDMAIL_DIR) smtp imap imapx $(IMAP4_DIR) $(NNTP_DIR) local groupwise $(HULA_DIR)
++SUBDIRS = pop3 $(SENDMAIL_DIR) smtp imap $(IMAPX_DIR) $(IMAP4_DIR) $(NNTP_DIR) local groupwise $(HULA_DIR)
+
+ -include $(top_srcdir)/git.mk
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2010-07-08 17:24:36.000000000 +0800
++++ git/configure.ac 2010-07-08 17:32:06.000000000 +0800
+@@ -1002,6 +1002,26 @@
+ AM_CONDITIONAL(ENABLE_IMAP4, [test x$enable_imap4 = xyes])
+
+ dnl ******************************
++dnl IMAPX code support.
++dnl ******************************
++AC_ARG_ENABLE(imapx,
++ AS_HELP_STRING([--enable-imapx=no/yes],
++ [Attempt to compile yet another, incomplete, very unsupported IMAPv4r1 implementation]),
++ [],[enable_imapx=no])
++
++if test "x$enable_imapx" = "xyes"; then
++ AC_DEFINE(ENABLE_IMAPX,1,[Really don't try this at home])
++ AC_PATH_PROG(GPERF, gperf)
++ if test -z "$GPERF" ; then
++ AC_MSG_ERROR([You need gperf to compile imapx provider])
++ fi
++ msg_imapx=yes
++else
++ msg_imapx=no
++fi
++AM_CONDITIONAL(ENABLE_IMAPX, [test x$enable_imapx = xyes])
++
++dnl ******************************
+ dnl Hula support
+ dnl ******************************
+ AC_ARG_ENABLE([hula],
+@@ -1541,3 +1561,7 @@
+ if test "x$msg_hula" = "xyes"; then
+ echo "Hula support: $msg_hula"
+ fi
++
++if test "x$msg_imapx" = "xyes"; then
++ echo "IMAPX support: $msg_imapx"
++fi
diff --git a/meta/packages/eds/eds-dbus_git.bb b/meta/packages/eds/eds-dbus_git.bb
index 30fbc821b..092765ea3 100644
--- a/meta/packages/eds/eds-dbus_git.bb
+++ b/meta/packages/eds/eds-dbus_git.bb
@@ -3,16 +3,20 @@ HOMEPAGE = "http://www.gnome.org/projects/evolution/"
BUGTRACKER = "https://bugzilla.gnome.org/"
LICENSE = "LGPLv2 & LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
+ file://camel/camel.h;endline=24;md5=b02175c88f821224746b347a89731a2b \
+ file://libedataserver/e-data-server-util.h;endline=23;md5=9df8127bd8cfdc5469e938fc710d1f40 \
+ file://calendar/libecal/e-cal.h;endline=24;md5=5d496b9b6fd2a4fdbbfc31ef9455c9d0"
DEPENDS = "intltool-native glib-2.0 gtk+ gconf dbus db gnome-common virtual/libiconv zlib libsoup-2.4 libglade libical gnome-keyring"
-PV = "2.29+git${SRCPV}"
-PR = "r5"
+PV = "2.30+git${SRCPV}"
+PR = "r0"
SRC_URI = "git://git.gnome.org/evolution-data-server;protocol=git \
file://oh-contact.patch;patch=1;pnum=0 \
file://nossl.patch;patch=1 \
- file://parallelmake.patch;patch=1 \
+ file://optional_imapx_provider.patch;patch=1 \
file://iconv-detect.h"
S = "${WORKDIR}/git"