summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/tinylogin/tinylogin-1.4/remove-index.patch11
-rw-r--r--meta/packages/tinylogin/tinylogin_1.4.bb5
2 files changed, 14 insertions, 2 deletions
diff --git a/meta/packages/tinylogin/tinylogin-1.4/remove-index.patch b/meta/packages/tinylogin/tinylogin-1.4/remove-index.patch
new file mode 100644
index 000000000..fc35002ba
--- /dev/null
+++ b/meta/packages/tinylogin/tinylogin-1.4/remove-index.patch
@@ -0,0 +1,11 @@
+--- /tmp/deluser.c 2007-05-13 10:38:19.000000000 +0200
++++ tinylogin-1.4/deluser.c 2007-05-13 10:38:50.185251000 +0200
+@@ -60,7 +60,7 @@
+ }
+ start++;
+
+- stop = index(start, '\n'); /* index is a BSD-ism */
++ stop = strchr(start, '\n'); /* index is a BSD-ism, strchr hopefully isn't */
+ b.start = start - buffer;
+ b.stop = stop - buffer;
+ return b;
diff --git a/meta/packages/tinylogin/tinylogin_1.4.bb b/meta/packages/tinylogin/tinylogin_1.4.bb
index 33f1c32ae..ad254bff6 100644
--- a/meta/packages/tinylogin/tinylogin_1.4.bb
+++ b/meta/packages/tinylogin/tinylogin_1.4.bb
@@ -5,12 +5,13 @@ changing passwords, and otherwise maintaining users \
and groups on an embedded system."
HOMEPAGE = "http://tinylogin.busybox.net/"
LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://tinylogin.busybox.net/downloads/tinylogin-${PV}.tar.bz2 \
file://cvs-20040608.patch;patch=1;pnum=1 \
file://add-system.patch;patch=1;pnum=1 \
- file://adduser-empty_pwd.patch;patch=1"
+ file://adduser-empty_pwd.patch;patch=1 \
+ file://remove-index.patch;patch=1"
EXTRA_OEMAKE = ""