summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xbitbake/bin/bitbake4
1 files changed, 2 insertions, 2 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index 0f4ff8817..6d74e5b85 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -155,13 +155,13 @@ Default BBFILES are the .bb files in the current directory.""" )
bb.utils.init_logger(bb.msg, configuration.verbose, configuration.debug,
configuration.debug_domains)
- cooker = bb.cooker.BBCooker(configuration, server)
-
# Clear away any spurious environment variables. But don't wipe the
# environment totally. This is necessary to ensure the correct operation
# of the UIs (e.g. for DISPLAY, etc.)
bb.utils.clean_environment()
+ cooker = bb.cooker.BBCooker(configuration, server)
+
cooker.parseCommandLine()
serverinfo = server.BitbakeServerInfo(cooker.server)