summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--handbook/Makefile3
-rw-r--r--handbook/ref-variables.xml7
-rw-r--r--meta-moblin/packages/linux/linux-moblin-2.6.33.2/defconfig-netbook8
-rw-r--r--meta-moblin/packages/linux/linux-moblin_2.6.33.2.bb2
-rw-r--r--meta/classes/packaged-staging.bbclass2
-rw-r--r--meta/classes/poky.bbclass17
-rw-r--r--meta/conf/distro/poky.conf2
-rw-r--r--meta/conf/machine/qemuppc.conf1
-rw-r--r--meta/packages/gnome/gnome-keyring_2.26.1.bb2
-rw-r--r--meta/packages/gypsy/gypsy_0.6.bb2
-rw-r--r--meta/packages/icu/icu-3.6.inc7
-rw-r--r--meta/packages/tasks/task-poky-tools.bb3
-rw-r--r--meta/packages/xorg-xserver/xserver-kdrive-1.7.99.2/nodolt.patch12
-rw-r--r--meta/packages/xorg-xserver/xserver-kdrive_1.7.99.2.bb5
-rw-r--r--meta/site/powerpc-linux4
15 files changed, 60 insertions, 17 deletions
diff --git a/handbook/Makefile b/handbook/Makefile
index 5dff1a874..502c951a7 100644
--- a/handbook/Makefile
+++ b/handbook/Makefile
@@ -9,7 +9,8 @@ pdf:
XSLTOPTS = --stringparam html.stylesheet style.css \
--stringparam chapter.autolabel 1 \
--stringparam appendix.autolabel 1 \
- --stringparam section.autolabel 1
+ --stringparam section.autolabel 1 \
+ --xinclude
##
# These URI should be rewritten by your distribution's xml catalog to
diff --git a/handbook/ref-variables.xml b/handbook/ref-variables.xml
index e4523bfdc..7aa360660 100644
--- a/handbook/ref-variables.xml
+++ b/handbook/ref-variables.xml
@@ -84,6 +84,13 @@
</glossdef>
</glossentry>
+ <glossentry id='var-BPN'><glossterm>BPN</glossterm>
+ <glossdef>
+ <para>Bare name of package with any suffixes like -cross -native
+ removed. </para>
+ </glossdef>
+ </glossentry>
+
</glossdiv>
<glossdiv id='var-glossary-c'><title>C</title>
diff --git a/meta-moblin/packages/linux/linux-moblin-2.6.33.2/defconfig-netbook b/meta-moblin/packages/linux/linux-moblin-2.6.33.2/defconfig-netbook
index b36e9a0b6..56ca00d6b 100644
--- a/meta-moblin/packages/linux/linux-moblin-2.6.33.2/defconfig-netbook
+++ b/meta-moblin/packages/linux/linux-moblin-2.6.33.2/defconfig-netbook
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.33.2
-# Mon Jun 7 22:35:35 2010
+# Thu Jun 10 18:03:03 2010
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -1460,14 +1460,14 @@ CONFIG_MOUSE_PS2_TRACKPOINT=y
# CONFIG_MOUSE_PS2_ELANTECH is not set
# CONFIG_MOUSE_PS2_SENTELIC is not set
CONFIG_MOUSE_PS2_TOUCHKIT=y
-CONFIG_MOUSE_SERIAL=m
+# CONFIG_MOUSE_SERIAL is not set
# CONFIG_MOUSE_APPLETOUCH is not set
# CONFIG_MOUSE_BCM5974 is not set
# CONFIG_MOUSE_INPORT is not set
# CONFIG_MOUSE_LOGIBM is not set
# CONFIG_MOUSE_PC110PAD is not set
-CONFIG_MOUSE_VSXXXAA=m
-# CONFIG_MOUSE_SYNAPTICS_I2C is not set
+CONFIG_MOUSE_VSXXXAA=y
+CONFIG_MOUSE_SYNAPTICS_I2C=y
CONFIG_INPUT_JOYSTICK=y
# CONFIG_JOYSTICK_ANALOG is not set
# CONFIG_JOYSTICK_A3D is not set
diff --git a/meta-moblin/packages/linux/linux-moblin_2.6.33.2.bb b/meta-moblin/packages/linux/linux-moblin_2.6.33.2.bb
index d0128e3da..fbb456adf 100644
--- a/meta-moblin/packages/linux/linux-moblin_2.6.33.2.bb
+++ b/meta-moblin/packages/linux/linux-moblin_2.6.33.2.bb
@@ -1,6 +1,6 @@
require linux-moblin.inc
-PR = "r0"
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_netbook = "1"
diff --git a/meta/classes/packaged-staging.bbclass b/meta/classes/packaged-staging.bbclass
index 6314e36aa..bd2dc1652 100644
--- a/meta/classes/packaged-staging.bbclass
+++ b/meta/classes/packaged-staging.bbclass
@@ -42,7 +42,7 @@ python () {
path = bb.data.getVar('PSTAGE_PKGPATH', d, 1)
path = path + bb.data.getVar('TMPDIR', d, 1).replace('/', '-')
bb.data.setVar('PSTAGE_PKGPATH', path, d)
- scan_cmd = "grep -Irl ${STAGING_DIR} ${PSTAGE_TMDPDIR_STAGE}"
+ scan_cmd = "grep -Irl ${STAGING_DIR} ${PSTAGE_TMPDIR_STAGE}"
bb.data.setVar('PSTAGE_SCAN_CMD', scan_cmd, d)
# PSTAGE_NATIVEDEPENDS lists the packages we need before we can use packaged
diff --git a/meta/classes/poky.bbclass b/meta/classes/poky.bbclass
index cf65b6ceb..7d3c28ffe 100644
--- a/meta/classes/poky.bbclass
+++ b/meta/classes/poky.bbclass
@@ -7,10 +7,23 @@ osc://.*/.* http://pokylinux.org/sources/
p4://.*/.* http://pokylinux.org/sources/
svk://.*/.* http://pokylinux.org/sources/
svn://.*/.* http://pokylinux.org/sources/
+
+bzr://.*/.* http://autobuilder.pokylinux.org/sources/
+cvs://.*/.* http://autobuilder.pokylinux.org/sources/
+git://.*/.* http://autobuilder.pokylinux.org/sources/
+hg://.*/.* http://autobuilder.pokylinux.org/sources/
+osc://.*/.* http://autobuilder.pokylinux.org/sources/
+p4://.*/.* http://autobuilder.pokylinux.org/sources/
+svk://.*/.* http://autobuilder.pokylinux.org/sources/
+svn://.*/.* http://autobuilder.pokylinux.org/sources/
}
MIRRORS_append () {
-ftp://.*/.* http://pokylinux.org/sources/
-http://.*/.* http://pokylinux.org/sources/
+ftp://.*/.* http://pokylinux.org/sources/
+http://.*/.* http://pokylinux.org/sources/
https://.*/.* http://pokylinux.org/sources/
+
+ftp://.*/.* http://autobuilder.pokylinux.org/sources/
+http://.*/.* http://autobuilder.pokylinux.org/sources/
+https://.*/.* http://autobuilder.pokylinux.org/sources/
}
diff --git a/meta/conf/distro/poky.conf b/meta/conf/distro/poky.conf
index ddebebb28..e0f33e29c 100644
--- a/meta/conf/distro/poky.conf
+++ b/meta/conf/distro/poky.conf
@@ -3,7 +3,7 @@
DISTRO = "poky"
DISTRO_NAME = "OpenedHand Linux (Poky)"
-DISTRO_VERSION = "3.2+snapshot-${DATE}"
+DISTRO_VERSION = "3.3+snapshot-${DATE}"
MAINTAINER = "OpenedHand <poky@openedhand.com>"
diff --git a/meta/conf/machine/qemuppc.conf b/meta/conf/machine/qemuppc.conf
index 91abb0792..6ca8ce8d2 100644
--- a/meta/conf/machine/qemuppc.conf
+++ b/meta/conf/machine/qemuppc.conf
@@ -3,6 +3,7 @@
#@DESCRIPTION: Machine configuration for running an PPC system under qemu emulation
TARGET_ARCH = "powerpc"
+PACKAGE_EXTRA_ARCHS = "ppc603e"
require conf/machine/include/qemu.inc
require conf/machine/include/tune-ppc603e.inc
diff --git a/meta/packages/gnome/gnome-keyring_2.26.1.bb b/meta/packages/gnome/gnome-keyring_2.26.1.bb
index cc111c949..6d1e33529 100644
--- a/meta/packages/gnome/gnome-keyring_2.26.1.bb
+++ b/meta/packages/gnome/gnome-keyring_2.26.1.bb
@@ -5,7 +5,7 @@ PR = "r1"
inherit autotools gnome pkgconfig
-DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native"
+DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf"
EXTRA_OECONF = "--disable-gtk-doc"
diff --git a/meta/packages/gypsy/gypsy_0.6.bb b/meta/packages/gypsy/gypsy_0.6.bb
index bd2fdaa0d..ee669e5ef 100644
--- a/meta/packages/gypsy/gypsy_0.6.bb
+++ b/meta/packages/gypsy/gypsy_0.6.bb
@@ -3,7 +3,7 @@ LICENSE = "GPL"
SECTION = "x11"
DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt"
-SRC_URI = "http://gypsy.freedesktop.org/gypsy-releases/gypsy-${PV}.tar.gz"
+SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz"
inherit autotools pkgconfig
diff --git a/meta/packages/icu/icu-3.6.inc b/meta/packages/icu/icu-3.6.inc
index e99fc4a20..9761908bd 100644
--- a/meta/packages/icu/icu-3.6.inc
+++ b/meta/packages/icu/icu-3.6.inc
@@ -1,8 +1,11 @@
-SRC_URI = "ftp://ftp.software.ibm.com/software/globalization/icu/3.6/icu4c-3_6-src.tgz \
+BASE_SRC_URI = "ftp://ftp.software.ibm.com/software/globalization/icu/3.6/icu4c-3_6-src.tgz \
file://gccfix.patch;patch=1 \
- file://noldlibpath.patch;patch=1 \
file://use-g++-for-linking.patch;patch=1"
+SRC_URI = "${BASE_SRC_URI} \
+ file://noldlibpath.patch;patch=1"
+SRC_URI_virtclass-native = "${BASE_SRC_URI}"
+
LICENSE = "ICU"
DEPENDS = "icu-native"
DEPENDS_virtclass-native = ""
diff --git a/meta/packages/tasks/task-poky-tools.bb b/meta/packages/tasks/task-poky-tools.bb
index cb9071833..4b6d21814 100644
--- a/meta/packages/tasks/task-poky-tools.bb
+++ b/meta/packages/tasks/task-poky-tools.bb
@@ -3,7 +3,7 @@
#
DESCRIPTION = "Tools tasks for Poky"
-PR = "r2"
+PR = "r3"
PACKAGES = "\
task-poky-tools-debug \
@@ -25,6 +25,7 @@ ALLOW_EMPTY = "1"
KEXECTOOLS ?= "kexec-tools"
KEXECTOOLS_mips ?= ""
KEXECTOOLS_mipsel ?= ""
+KEXECTOOLS_powerpc ?= ""
RDEPENDS_task-poky-tools-debug = "\
gdb \
diff --git a/meta/packages/xorg-xserver/xserver-kdrive-1.7.99.2/nodolt.patch b/meta/packages/xorg-xserver/xserver-kdrive-1.7.99.2/nodolt.patch
new file mode 100644
index 000000000..6b34032a3
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-kdrive-1.7.99.2/nodolt.patch
@@ -0,0 +1,12 @@
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2009-01-15 20:35:31.000000000 +0000
++++ git/configure.ac 2009-01-15 20:35:38.000000000 +0000
+@@ -62,7 +62,6 @@
+ AC_LIBTOOL_WIN32_DLL
+ AC_DISABLE_STATIC
+ AC_PROG_LIBTOOL
+-DOLT
+ AC_PROG_MAKE_SET
+ PKG_PROG_PKG_CONFIG
+ AC_PROG_LEX
diff --git a/meta/packages/xorg-xserver/xserver-kdrive_1.7.99.2.bb b/meta/packages/xorg-xserver/xserver-kdrive_1.7.99.2.bb
index f0fb6e2d1..7ca88e64e 100644
--- a/meta/packages/xorg-xserver/xserver-kdrive_1.7.99.2.bb
+++ b/meta/packages/xorg-xserver/xserver-kdrive_1.7.99.2.bb
@@ -7,7 +7,7 @@ RDEPENDS_${PN} += "xkeyboard-config"
EXTRA_OECONF += "--disable-glx"
PE = "1"
-PR = "r24"
+PR = "r25"
SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
file://extra-kmodes.patch;patch=1 \
@@ -22,6 +22,7 @@ SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
file://hide-cursor-and-ppm-root.patch;patch=1 \
file://fbdev_xrandr_ioctl.patch;patch=1 \
file://fix-newer-xorg-headers.patch;patch=1 \
- file://crosscompile.patch;patch=1"
+ file://crosscompile.patch;patch=1 \
+ file://nodolt.patch;patch=1"
S = "${WORKDIR}/xorg-server-${PV}"
diff --git a/meta/site/powerpc-linux b/meta/site/powerpc-linux
index bea14d5a7..856701d17 100644
--- a/meta/site/powerpc-linux
+++ b/meta/site/powerpc-linux
@@ -3,3 +3,7 @@ libc_cv_ppc_machine=${libc_cv_ppc_machine=yes}
libc_cv_mlong_double_128ibm=${libc_cv_mlong_double_128ibm=yes}
libc_cv_mabi_ibmlongdouble=${libc_cv_mabi_ibmlongdouble=yes}
libc_cv_mlong_double_128=${libc_cv_mlong_double_128=yes}
+
+# popt
+ac_cv_va_copy=${ac_cv_va_copy=yes}
+ac_cv___va_copy=${ac_cv___va_copy=yes}