summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/gcc/gcc-native.inc28
-rw-r--r--meta/packages/gcc/gcc-native_3.4.4.bb2
2 files changed, 30 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-native.inc b/meta/packages/gcc/gcc-native.inc
new file mode 100644
index 000000000..3cf20a458
--- /dev/null
+++ b/meta/packages/gcc/gcc-native.inc
@@ -0,0 +1,28 @@
+DEPENDS = ""
+PACKAGES = ""
+PROVIDES = "gcc-native-${PV}"
+
+inherit native
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+
+# This is intended to be a -very- basic config
+EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
+ --with-newlib \
+ --disable-shared \
+ --disable-threads \
+ --disable-multilib \
+ --disable-__cxa_atexit \
+ --enable-languages=c \
+ --enable-target-optspace \
+ --program-prefix=${TARGET_PREFIX}"
+
+do_install () {
+ :
+}
+
+do_stage () {
+ cd gcc
+ oe_runmake install-common install-headers install-libgcc
+ install -m 0755 xgcc ${STAGING_BINDIR}/gcc-${PV}
+}
diff --git a/meta/packages/gcc/gcc-native_3.4.4.bb b/meta/packages/gcc/gcc-native_3.4.4.bb
new file mode 100644
index 000000000..2e5d3ac26
--- /dev/null
+++ b/meta/packages/gcc/gcc-native_3.4.4.bb
@@ -0,0 +1,2 @@
+require gcc_${PV}.bb
+require gcc-native.inc