summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/classes/insane.bbclass6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index 88e77a75e..0c9bde349 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -276,8 +276,10 @@ def package_qa_check_license(workdir, d):
lic_files = bb.data.getVar('LIC_FILES_CHKSUM', d, True)
if not lic_files:
- bb.error(" Recipe (.bb) file does not have license file information (LIC_FILES_CHKSUM)")
- return False
+ # just throw a warning now. Once licensing data in entered for enough of the recipes,
+ # this will be converted into error and False will be returned.
+ bb.warn(" Recipe (.bb) file does not have license file information (LIC_FILES_CHKSUM)")
+ return True
srcdir = bb.data.getVar('S', d, True)