summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/sato-icon-theme/sato-icon-theme.inc2
-rw-r--r--meta/packages/sato-icon-theme/sato-icon-theme/iconpath-option.patch51
-rw-r--r--meta/packages/sato-icon-theme/sato-icon-theme_0.4.1.bb3
3 files changed, 55 insertions, 1 deletions
diff --git a/meta/packages/sato-icon-theme/sato-icon-theme.inc b/meta/packages/sato-icon-theme/sato-icon-theme.inc
index ca99d7a59..a1669c6f2 100644
--- a/meta/packages/sato-icon-theme/sato-icon-theme.inc
+++ b/meta/packages/sato-icon-theme/sato-icon-theme.inc
@@ -14,6 +14,8 @@ FILES_${PN} += "${datadir}"
PACKAGE_ARCH = "all"
+EXTRA_OECONF += "--with-iconmap=${STAGING_LIBDIR_NATIVE}/../libexec/icon-name-mapping"
+
pkg_postinst_${PN} () {
if [ "x$D" != "x" ]; then
exit 1
diff --git a/meta/packages/sato-icon-theme/sato-icon-theme/iconpath-option.patch b/meta/packages/sato-icon-theme/sato-icon-theme/iconpath-option.patch
new file mode 100644
index 000000000..cfa6a0dd1
--- /dev/null
+++ b/meta/packages/sato-icon-theme/sato-icon-theme/iconpath-option.patch
@@ -0,0 +1,51 @@
+pkg-config will only search the target sysroot and we want the native script. This
+patch adds an option to allow the path to the tool to be specified.
+
+RP - 12/8/10
+
+Index: sato-icon-theme-0.4.1/configure.ac
+===================================================================
+--- sato-icon-theme-0.4.1.orig/configure.ac 2010-08-12 12:23:25.000000000 +0100
++++ sato-icon-theme-0.4.1/configure.ac 2010-08-12 12:48:14.000000000 +0100
+@@ -11,20 +11,29 @@
+
+ UTILS_REQUIRED=0.8.2
+
+-AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
+-PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
+- have_utils=yes, have_utils=no)
+-if test "x$have_utils" = "xyes"; then
+- UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
+- ICONMAP="$UTILS_PATH/icon-name-mapping"
+- AC_SUBST(ICONMAP)
+- AC_MSG_RESULT([yes])
+-else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build
+- and install sato-icon-theme])
++PKG_PROG_PKG_CONFIG()
++
++AC_ARG_WITH(iconmap,
++ AC_HELP_STRING([--with-iconmap=<dir>], [The location of the icon-name-mapping script to use]),
++ ICONMAP=$withval, ICONMAP="")
++
++if test "x$ICONMAP" = "x"; then
++ AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
++ PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
++ have_utils=yes, have_utils=no)
++ if test "x$have_utils" = "xyes"; then
++ UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
++ ICONMAP="$UTILS_PATH/icon-name-mapping"
++
++ AC_MSG_RESULT([yes])
++ else
++ AC_MSG_RESULT([no])
++ AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build
++ and install sato-icon-theme])
++ fi
+ fi
+
++AC_SUBST(ICONMAP)
+
+ AC_CONFIG_FILES([
+ Makefile
diff --git a/meta/packages/sato-icon-theme/sato-icon-theme_0.4.1.bb b/meta/packages/sato-icon-theme/sato-icon-theme_0.4.1.bb
index 1dc8f9381..aa976b102 100644
--- a/meta/packages/sato-icon-theme/sato-icon-theme_0.4.1.bb
+++ b/meta/packages/sato-icon-theme/sato-icon-theme_0.4.1.bb
@@ -2,4 +2,5 @@ require sato-icon-theme.inc
DEPENDS += "icon-naming-utils-native"
-SRC_URI = "http://pokylinux.org/releases/sato/${PN}-${PV}.tar.gz"
+SRC_URI = "http://pokylinux.org/releases/sato/${PN}-${PV}.tar.gz \
+ file://iconpath-option.patch"