summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--openembedded/conf/local.conf.sample7
-rwxr-xr-xsetdevenv11
2 files changed, 12 insertions, 6 deletions
diff --git a/openembedded/conf/local.conf.sample b/openembedded/conf/local.conf.sample
index 7a7afb427..489b0deb1 100644
--- a/openembedded/conf/local.conf.sample
+++ b/openembedded/conf/local.conf.sample
@@ -20,11 +20,12 @@
# expansion. Stuff like starting with ${HOME} or ${TOPDIR} is ok).
# Use this to specify where BitBake should place the downloaded sources into
-DL_DIR = "${HOME}/sources"
+DL_DIR = "POKYROOT/sources"
# Delete the line below. Then specify which .bb files to consider for
# your build. Typically this will be something like BBFILES = "/path/to/openembedded/packages/*/*.bb"
-BBFILES := "${@bb.fatal('Edit your conf/local.conf: BBFILES')}"
+#BBFILES := "${@bb.fatal('Edit your conf/local.conf: BBFILES')}"
+BBFILES := "POKYROOT/openembedded/packages/*/*.bb"
# Use the BBMASK below to instruct BitBake to _NOT_ consider some .bb files
# This is a regulary expression, so be sure to get your parenthesis balanced.
@@ -119,4 +120,4 @@ BBINCLUDELOGS = "yes"
CVS_TARBALL_STASH = "http://www.oesources.org/source/current/"
# EDIT THIS FILE and then remove the line below before using!
-REMOVE_THIS_LINE:="${@oe.fatal('Read the comments in your conf/local.conf')}"
+#REMOVE_THIS_LINE:="${@oe.fatal('Read the comments in your conf/local.conf')}"
diff --git a/setdevenv b/setdevenv
index c6945ca16..0c3c572fe 100755
--- a/setdevenv
+++ b/setdevenv
@@ -4,7 +4,7 @@
# Change this to the location of this file.
# Also update the locations at the top of conf/local.conf
#
-OEROOT=/usr/ohoe/
+OEROOT=`pwd`
BBDIR=$OEROOT/bitbake/
PKGDIR=$OEROOT/openembedded/
@@ -20,10 +20,15 @@ PKGDIR=`readlink -f $PKGDIR`
BUILDDIR=`readlink -f $BUILDDIR`
if ! (test -d $BBDIR && test -d $PKGDIR && test -d $BUILDDIR); then
- echo >&2 "Error: Not all directories exist!"
+ echo >&2 "Error: Not all directories exist! Did you run this script in poky directory?"
exit 1
fi
-
+
+if !(test -r $PKGDIR/conf/local.conf); then
+ echo "Setting up initial '$PKGDIR/conf/local.conf'."
+ cat $PKGDIR/conf/local.conf.sample | sed -e"s|POKYROOT|${OEROOT}|" > $PKGDIR/conf/local.conf
+fi
+
BBPATH=$BBDIR
if test x"$BBDIR" != x"$PKGDIR"; then
BBPATH=$PKGDIR:$BBPATH