summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/futimens.patch44
-rw-r--r--meta/packages/coreutils/coreutils_5.3.0.bb3
2 files changed, 46 insertions, 1 deletions
diff --git a/meta/packages/coreutils/coreutils-5.3.0/futimens.patch b/meta/packages/coreutils/coreutils-5.3.0/futimens.patch
new file mode 100644
index 000000000..3cb2b6ab3
--- /dev/null
+++ b/meta/packages/coreutils/coreutils-5.3.0/futimens.patch
@@ -0,0 +1,44 @@
+Index: coreutils-5.3.0/lib/utimens.c
+===================================================================
+--- coreutils-5.3.0.orig/lib/utimens.c 2005-01-03 22:19:15.000000000 +0000
++++ coreutils-5.3.0/lib/utimens.c 2007-07-01 19:12:32.000000000 +0000
+@@ -55,8 +55,8 @@
+ If TIMESPEC is null, set the time stamps to the current time. */
+
+ int
+-futimens (int fd ATTRIBUTE_UNUSED,
+- char const *file, struct timespec const timespec[2])
++gl_futimens (int fd ATTRIBUTE_UNUSED,
++ char const *file, struct timespec const timespec[2])
+ {
+ /* There's currently no interface to set file timestamps with
+ nanosecond resolution, so do the best we can, discarding any
+@@ -117,5 +117,5 @@
+ int
+ utimens (char const *file, struct timespec const timespec[2])
+ {
+- return futimens (-1, file, timespec);
++ return gl_futimens (-1, file, timespec);
+ }
+Index: coreutils-5.3.0/lib/utimens.h
+===================================================================
+--- coreutils-5.3.0.orig/lib/utimens.h 2004-11-23 20:54:33.000000000 +0000
++++ coreutils-5.3.0/lib/utimens.h 2007-07-01 19:12:37.000000000 +0000
+@@ -1,3 +1,3 @@
+ #include "timespec.h"
+-int futimens (int, char const *, struct timespec const [2]);
++int gl_futimens (int, char const *, struct timespec const [2]);
+ int utimens (char const *, struct timespec const [2]);
+Index: coreutils-5.3.0/src/touch.c
+===================================================================
+--- coreutils-5.3.0.orig/src/touch.c 2004-11-23 20:54:35.000000000 +0000
++++ coreutils-5.3.0/src/touch.c 2007-07-01 19:11:52.000000000 +0000
+@@ -191,7 +191,7 @@
+ t = timespec;
+ }
+
+- ok = (futimens (fd, file, t) == 0);
++ ok = (gl_futimens (fd, file, t) == 0);
+ if (fd != -1)
+ ok &= (close (fd) == 0);
+
diff --git a/meta/packages/coreutils/coreutils_5.3.0.bb b/meta/packages/coreutils/coreutils_5.3.0.bb
index 61d25543a..bef76bed7 100644
--- a/meta/packages/coreutils/coreutils_5.3.0.bb
+++ b/meta/packages/coreutils/coreutils_5.3.0.bb
@@ -1,9 +1,10 @@
require coreutils.inc
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://install-cross.patch;patch=1;pnum=0 \
+ file://futimens.patch;patch=1 \
file://man.patch;patch=1 \
file://rename-tee-for-glibc2.5.patch;patch=1 \
file://uptime-pow-lib.patch;patch=1"