summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--openembedded/packages/gtk+/gtk+-2.6.7/gtklabel-center.patch13
-rw-r--r--openembedded/packages/gtk+/gtk+_2.6.7.bb3
2 files changed, 15 insertions, 1 deletions
diff --git a/openembedded/packages/gtk+/gtk+-2.6.7/gtklabel-center.patch b/openembedded/packages/gtk+/gtk+-2.6.7/gtklabel-center.patch
new file mode 100644
index 000000000..b368cb4b7
--- /dev/null
+++ b/openembedded/packages/gtk+/gtk+-2.6.7/gtklabel-center.patch
@@ -0,0 +1,13 @@
+--- gtk+-2.6.7/gtk/gtklabel.c~ 2006-05-25 15:35:15.000000000 +0100
++++ gtk+-2.6.7/gtk/gtklabel.c 2006-05-30 11:40:37.000000000 +0100
+@@ -2185,8 +2185,8 @@
+ req_width - misc->xpad);
+
+ y = floor (widget->allocation.y + (gint)misc->ypad
+- + MAX (((widget->allocation.height - widget->requisition.height) * misc->yalign)
+- + 0.5, 0));
++ + ((widget->allocation.height - widget->requisition.height) * misc->yalign)
++ + 0.5);
+
+ if (xp)
+ *xp = x;
diff --git a/openembedded/packages/gtk+/gtk+_2.6.7.bb b/openembedded/packages/gtk+/gtk+_2.6.7.bb
index b27607231..080db44c0 100644
--- a/openembedded/packages/gtk+/gtk+_2.6.7.bb
+++ b/openembedded/packages/gtk+/gtk+_2.6.7.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.gtk.org"
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0 pango atk jpeg libpng libxext libxcursor gtk-doc libgcrypt"
-PR = "r4"
+PR = "r5"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://no-demos.patch;patch=1 \
@@ -15,6 +15,7 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://hardcoded_libtool.patch;patch=1 \
file://disable-tooltips.patch;patch=1 \
file://gtklabel-resize-patch;patch=1 \
+ file://gtklabel-center.patch;patch=1 \
file://menu-deactivate.patch;patch=1 \
file://scroll-timings.patch;patch=1 \
file://small-gtkfilesel.patch;patch=1 \