summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xmeta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session17
-rw-r--r--meta/packages/matchbox-poky/matchbox-poky_0.1.bb2
-rwxr-xr-xmeta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session20
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato_0.1.bb2
4 files changed, 2 insertions, 39 deletions
diff --git a/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session b/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
index 36cfee7c6..4eea748d4 100755
--- a/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
+++ b/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
@@ -1,24 +1,7 @@
#!/bin/sh
-module_id() {
- awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
-}
-
SHOWCURSOR="no"
-## Start up machine specific input devices. Really needs to go in its own session
-case `module_id` in
- # On Zaurus models, zaurusd takes care of mbinputmgr for us in its hinge scripts
- "Generic OMAP1510/1610/1710")
- /usr/bin/mbinputmgr &
- ;;
- # qemu machines.. likely need better detection
- "ARM-IntegratorCP" | "ARM-Versatile PB")
- /usr/bin/mbinputmgr &
- #SHOWCURSOR="yes"
- ;;
-esac
-
## All this should be done by themeing/xsettings.. ##
matchbox-desktop --icon-size 48 \
--icon-padding 64 \
diff --git a/meta/packages/matchbox-poky/matchbox-poky_0.1.bb b/meta/packages/matchbox-poky/matchbox-poky_0.1.bb
index 64c17c58f..f486a526c 100644
--- a/meta/packages/matchbox-poky/matchbox-poky_0.1.bb
+++ b/meta/packages/matchbox-poky/matchbox-poky_0.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-theme-clearlooks"
-PR = "r21"
+PR = "r23"
SRC_URI = "file://etc"
S = ${WORKDIR}
diff --git a/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session b/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
index b3bde29b4..5b41cbe4a 100755
--- a/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
+++ b/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
@@ -1,27 +1,7 @@
#!/bin/sh
-module_id() {
- awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
-}
-
SHOWCURSOR="no"
-## Start up machine specific input devices. Really needs to go in its own session
-case `module_id` in
- # On Zaurus models, zaurusd takes care of mbinputmgr for us in its hinge scripts
- "Generic OMAP1510/1610/1710")
- matchbox-keyboard --daemon &
- ;;
- "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi" | \
- "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi")
- matchbox-keyboard --daemon --orientation portrait &
- ;;
- # qemu machines.. likely need better detection
- "ARM-IntegratorCP" | "ARM-Versatile PB")
- #SHOWCURSOR="yes"
- ;;
-esac
-
## All this should be done by themeing/xsettings.. ##
matchbox-desktop &
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
index 3cda6480d..b582d8858 100644
--- a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
+++ b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2"
-PR = "r11"
+PR = "r12"
SRC_URI = "file://etc"
S = ${WORKDIR}