summaryrefslogtreecommitdiff
path: root/bitbake-dev/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bitbake-dev/bin')
-rwxr-xr-xbitbake-dev/bin/bitbake13
1 files changed, 4 insertions, 9 deletions
diff --git a/bitbake-dev/bin/bitbake b/bitbake-dev/bin/bitbake
index 247b54fcd..87284c08f 100755
--- a/bitbake-dev/bin/bitbake
+++ b/bitbake-dev/bin/bitbake
@@ -141,15 +141,10 @@ Default BBFILES are the .bb files in the current directory.""" )
cooker = bb.cooker.BBCooker(configuration)
- # Optionally clean up the environment
- if 'BB_PRESERVE_ENV' not in os.environ:
- if 'BB_ENV_WHITELIST' in os.environ:
- good_vars = os.environ['BB_ENV_WHITELIST'].split()
- else:
- good_vars = bb.utils.preserved_envvars_list()
- if 'BB_ENV_EXTRAWHITE' in os.environ:
- good_vars.extend(os.environ['BB_ENV_EXTRAWHITE'].split())
- bb.utils.filter_environment(good_vars)
+ # Clear away any spurious environment variables. But don't wipe the
+ # environment totally. This is necessary to ensure the correct operation
+ # of the UIs (e.g. for DISPLAY, etc.)
+ bb.utils.clean_environment()
cooker.parseConfiguration()
host = cooker.server.host