summaryrefslogtreecommitdiff
path: root/bitbake/contrib/vim/ftdetect/bitbake.vim
diff options
context:
space:
mode:
Diffstat (limited to 'bitbake/contrib/vim/ftdetect/bitbake.vim')
-rw-r--r--bitbake/contrib/vim/ftdetect/bitbake.vim24
1 files changed, 0 insertions, 24 deletions
diff --git a/bitbake/contrib/vim/ftdetect/bitbake.vim b/bitbake/contrib/vim/ftdetect/bitbake.vim
deleted file mode 100644
index 179e4d988..000000000
--- a/bitbake/contrib/vim/ftdetect/bitbake.vim
+++ /dev/null
@@ -1,24 +0,0 @@
-" Vim filetype detection file
-" Language: BitBake
-" Author: Ricardo Salveti <rsalveti@rsalveti.net>
-" Copyright: Copyright (C) 2008 Ricardo Salveti <rsalveti@rsalveti.net>
-" Licence: You may redistribute this under the same terms as Vim itself
-"
-" This sets up the syntax highlighting for BitBake files, like .bb, .bbclass and .inc
-
-if &compatible || version < 600
- finish
-endif
-
-" .bb and .bbclass
-au BufNewFile,BufRead *.b{b,bclass} set filetype=bitbake
-
-" .inc
-au BufNewFile,BufRead *.inc set filetype=bitbake
-
-" .conf
-au BufNewFile,BufRead *.conf
- \ if (match(expand("%:p:h"), "conf") > 0) |
- \ set filetype=bitbake |
- \ endif
-