summaryrefslogtreecommitdiff
path: root/documentation/bsp-guide/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'documentation/bsp-guide/Makefile')
-rw-r--r--documentation/bsp-guide/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/documentation/bsp-guide/Makefile b/documentation/bsp-guide/Makefile
new file mode 100644
index 000000000..7e8d21690
--- /dev/null
+++ b/documentation/bsp-guide/Makefile
@@ -0,0 +1,35 @@
+all: html pdf tarball
+
+pdf:
+ ../tools/poky-docbook-to-pdf bsp-guide.xml ../template
+
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
+ --xinclude
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
+XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
+
+html:
+# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
+ xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSL_XHTML_URI) bsp-guide.xml
+
+tarball: html
+ tar -cvzf bsp-guide.tgz style.css bsp-guide.html figures/poky-ref-manual.png
+
+validate:
+ xmllint --postvalid --xinclude --noout bsp-guide.xml
+
+OUTPUTS = bsp-guide.pdf bsp-guide.html
+SOURCES = *.png *.xml *.css *.svg
+
+publish:
+ scp -r $(OUTPUTS) $(SOURCES) o-hand.com:/srv/www/pokylinux.org/doc/
+
+clean:
+ rm -f $(OUTPUTS)