summaryrefslogtreecommitdiff
path: root/meta-emenlow/packages/libva
diff options
context:
space:
mode:
Diffstat (limited to 'meta-emenlow/packages/libva')
-rw-r--r--meta-emenlow/packages/libva/libva-0.31.0/libdrm-poulsbo.patch26
-rw-r--r--meta-emenlow/packages/libva/libva_0.31.0.bb47
2 files changed, 50 insertions, 23 deletions
diff --git a/meta-emenlow/packages/libva/libva-0.31.0/libdrm-poulsbo.patch b/meta-emenlow/packages/libva/libva-0.31.0/libdrm-poulsbo.patch
new file mode 100644
index 000000000..795ba6252
--- /dev/null
+++ b/meta-emenlow/packages/libva/libva-0.31.0/libdrm-poulsbo.patch
@@ -0,0 +1,26 @@
+# Make the libva depend on libdrm-poulsbo instead of libdrm so that the
+# emenlow libdrm can coexist with the normal libdrm.
+# jdike@linux.intel.com
+
+Index: libva-0.31.0/configure.ac
+===================================================================
+--- libva-0.31.0.orig/configure.ac
++++ libva-0.31.0/configure.ac
+@@ -99,14 +99,14 @@ AC_SYS_LARGEFILE
+ PKG_CHECK_MODULES([X11], [x11])
+ PKG_CHECK_MODULES([XEXT],[xext])
+ PKG_CHECK_MODULES([XFIXES], [xfixes])
+-PKG_CHECK_MODULES([DRM], [libdrm])
++PKG_CHECK_MODULES([DRM], [libdrm-poulsbo])
+
+ PKG_CHECK_MODULES(GEN4ASM, [intel-gen4asm >= 1.0], [gen4asm=yes], [gen4asm=no])
+ AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)
+
+ # Check for libdrm >= 2.4 (needed for i965_drv_video.so)
+-if test x$enable_i965_driver = xyes && ! $PKG_CONFIG --atleast-version=2.4 libdrm; then
+- AC_MSG_WARN([libdrm < 2.4 found, disabling build of i965 video driver])
++if test x$enable_i965_driver = xyes && ! $PKG_CONFIG --atleast-version=2.4 libdrm-poulsbo; then
++ AC_MSG_WARN([libdrm-poulsbo < 2.4 found, disabling build of i965 video driver])
+ enable_i965_driver=no
+ fi
+ AM_CONDITIONAL(BUILD_I965_DRIVER, test x$enable_i965_driver = xyes)
diff --git a/meta-emenlow/packages/libva/libva_0.31.0.bb b/meta-emenlow/packages/libva/libva_0.31.0.bb
index bd9f758b0..0bc782f9d 100644
--- a/meta-emenlow/packages/libva/libva_0.31.0.bb
+++ b/meta-emenlow/packages/libva/libva_0.31.0.bb
@@ -1,32 +1,33 @@
DESCRIPTION = "Video Acceleration (VA) API for Linux"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=efc13a0998e678466e556756613c582e"
-PR = "r0"
+PR = "r1"
inherit autotools
SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libva_0.31.0-1+sds9.1ubuntu1.tar.gz \
- file://033_g45_add_rgba_subpic.patch;patch=1 \
- file://034_g45_fix_return_for_unimpl.patch;patch=1 \
- file://035_g45_add_yv12_image_format.patch;patch=1 \
- file://036_g45_add_vaGetImage.patch;patch=1 \
- file://037_g45_add_vaPutImage.patch;patch=1 \
- file://038_g45_vaPutSurface_cliprects.patch;patch=1 \
- file://102_attribute_visibility.patch;patch=1 \
- file://103_fix_vainfo_deps.patch;patch=1 \
- file://104_fix_libva_pkgconfig_deps.patch;patch=1 \
- file://105_dont_search_LIBGL_DRIVERS_PATH.patch;patch=1 \
- file://108_drivers_path.patch;patch=1 \
- file://203_fix_fglrx_detection.patch;patch=1 \
- file://204_check_ATIFGLEXTENSION.patch;patch=1 \
- file://300_sds_version.patch;patch=1 \
- file://301_vdpau_mpeg4.patch;patch=1 \
- file://320_move_vaPutSurface_flags_def.patch;patch=1 \
- file://321_libva_glx.base.patch;patch=1 \
- file://322_libva_glx.patch;patch=1 \
- file://390_compat.base.patch;patch=1 \
- file://391_compat.patch;patch=1 \
- file://392_compat.dso.patch;patch=1"
+ file://033_g45_add_rgba_subpic.patch \
+ file://034_g45_fix_return_for_unimpl.patch \
+ file://035_g45_add_yv12_image_format.patch \
+ file://036_g45_add_vaGetImage.patch \
+ file://037_g45_add_vaPutImage.patch \
+ file://038_g45_vaPutSurface_cliprects.patch \
+ file://102_attribute_visibility.patch \
+ file://103_fix_vainfo_deps.patch \
+ file://104_fix_libva_pkgconfig_deps.patch \
+ file://105_dont_search_LIBGL_DRIVERS_PATH.patch \
+ file://108_drivers_path.patch \
+ file://203_fix_fglrx_detection.patch \
+ file://204_check_ATIFGLEXTENSION.patch \
+ file://300_sds_version.patch \
+ file://301_vdpau_mpeg4.patch \
+ file://320_move_vaPutSurface_flags_def.patch \
+ file://321_libva_glx.base.patch \
+ file://322_libva_glx.patch \
+ file://390_compat.base.patch \
+ file://391_compat.patch \
+ file://392_compat.dso.patch \
+ file://libdrm-poulsbo.patch"
export LDFLAGS="-Wl,-z,defs"
@@ -34,5 +35,5 @@ EXTRA_OECONF = "--disable-i965-driver"
FILES_${PN} += "${libdir}/va/drivers/*"
-COMAPTIBLE_MACHINE = "emenlow"
+COMPATIBLE_MACHINE = "emenlow"
PACKAGE_ARCH = "${MACHINE_ARCH}"