summaryrefslogtreecommitdiff
path: root/meta-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/packages/gnome/libbonobo.inc28
-rw-r--r--meta-gnome/packages/gnome/libbonoboui_2.18.0.bb44
-rw-r--r--meta-gnome/packages/gnome/libgnome_2.24.0.bb3
-rw-r--r--meta-gnome/packages/gnome/libgnomeui_2.24.0.bb4
-rw-r--r--meta-gnome/packages/gnome/orbit2_2.14.16.bb16
-rw-r--r--meta-gnome/packages/gthumb/gthumb_2.10.11.bb4
6 files changed, 0 insertions, 99 deletions
diff --git a/meta-gnome/packages/gnome/libbonobo.inc b/meta-gnome/packages/gnome/libbonobo.inc
index 9f3642b80..db5c58a51 100644
--- a/meta-gnome/packages/gnome/libbonobo.inc
+++ b/meta-gnome/packages/gnome/libbonobo.inc
@@ -27,38 +27,10 @@ do_configure_prepend() {
install ${WORKDIR}/gtk-doc.make ./
}
-ACTIVATION_HEADERS = "Bonobo_Unknown.h Bonobo_GenericFactory.h Bonobo_Activation_types.h \
- bonobo-activation.h bonobo-activation-async.h bonobo-activation-activate.h \
- bonobo-activation-init.h bonobo-activation-shlib.h bonobo-activation-register.h \
- bonobo-activation-server-info.h bonobo-activation-version.h"
-
-BONOBO_HEADERS = "Bonobo.h bonobo-arg.h bonobo-context.h bonobo-event-source.h bonobo-exception.h \
- bonobo-generic-factory.h bonobo-item-container.h bonobo-item-handler.h \
- bonobo-listener.h bonobo-main.h bonobo-macros.h bonobo-moniker-extender.h \
- bonobo-moniker-simple.h bonobo-moniker-util.h bonobo-moniker.h bonobo-object.h \
- bonobo-foreign-object.h bonobo-persist-file.h bonobo-persist-stream.h \
- bonobo-persist.h bonobo-persist-client.h bonobo-property-bag.h \
- bonobo-property-bag-client.h bonobo-shlib-factory.h bonobo-storage.h \
- bonobo-stream.h bonobo-stream-client.h bonobo-stream-memory.h \
- bonobo-storage-memory.h bonobo-xobject.h bonobo-i18n.h bonobo-types.h \
- bonobo-app-client.h bonobo-application.h"
-
do_compile() {
oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
}
-do_stage() {
- install -d ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation
- for i in ${ACTIVATION_HEADERS}; do install -m 0644 bonobo-activation/$i ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation/; done
- install -d ${STAGING_INCDIR}/libbonobo-2.0/bonobo
- for i in ${BONOBO_HEADERS}; do install -m 0644 bonobo/$i ${STAGING_INCDIR}/libbonobo-2.0/bonobo/; done
- install -m 0644 libbonobo.h ${STAGING_INCDIR}/libbonobo-2.0/
- install -d ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
- install idl/*.idl ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
- oe_libinstall -so -C bonobo libbonobo-2 ${STAGING_LIBDIR}
- oe_libinstall -so -C bonobo-activation libbonobo-activation ${STAGING_LIBDIR}
-}
-
do_install() {
oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
}
diff --git a/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb b/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
index 53380c6fa..85840f705 100644
--- a/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
+++ b/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
@@ -13,47 +13,3 @@ FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \
DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
EXTRA_OECONF = "--disable-gtk-doc"
-
-HEADERS = " \
-bonobo/bonobo-zoomable.h \
-bonobo/bonobo-ui-component.h \
-bonobo/bonobo-dock-layout.h \
-bonobo/bonobo-ui-type-builtins.h \
-bonobo/bonobo-canvas-component.h \
-bonobo/bonobo-widget.h \
-bonobo/bonobo-ui-engine.h \
-bonobo/bonobo-window.h \
-bonobo/bonobo-ui-toolbar.h \
-bonobo/bonobo-dock-band.h \
-bonobo/bonobo-ui-toolbar-item.h \
-bonobo/bonobo-control.h \
-bonobo/bonobo-dock-item.h \
-bonobo/bonobo-ui-config-widget.h \
-bonobo/bonobo-zoomable-frame.h \
-bonobo/bonobo-control-frame.h \
-bonobo/bonobo-dock.h \
-bonobo/bonobo-ui-main.h \
-bonobo/bonobo-canvas-item.h \
-bonobo/bonobo-ui-node.h \
-bonobo/bonobo-socket.h \
-bonobo/bonobo-selector.h \
-bonobo/bonobo-ui-sync.h \
-bonobo/bonobo-ui-util.h \
-bonobo/bonobo-plug.h \
-bonobo/bonobo-ui-toolbar-button-item.h \
-bonobo/bonobo-ui-toolbar-toggle-button-item.h \
-bonobo/bonobo-ui-container.h \
-bonobo/bonobo-file-selector-util.h \
-bonobo/bonobo-property-control.h \
-bonobo/bonobo-selector-widget.h \
-libbonoboui.h \
-bonobo.h \
-"
-
-do_stage() {
- install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
- for i in ${HEADERS}; do
- install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
- done
- oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
-}
diff --git a/meta-gnome/packages/gnome/libgnome_2.24.0.bb b/meta-gnome/packages/gnome/libgnome_2.24.0.bb
index 549cda285..21c5aaa8c 100644
--- a/meta-gnome/packages/gnome/libgnome_2.24.0.bb
+++ b/meta-gnome/packages/gnome/libgnome_2.24.0.bb
@@ -14,6 +14,3 @@ FILES_${PN} += "${libdir}/bonobo/servers ${libdir}/bonobo/monikers/*.so \
FILES_${PN}-dev += "${libdir}/bonobo/monikers/*a"
FILES_${PN}-dbg += "${libdir}/bonobo/monikers/.debug"
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb b/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
index d21694214..c379cee72 100644
--- a/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
+++ b/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
@@ -18,7 +18,3 @@ EXTRA_OECONF = "--disable-gtk-doc"
do_configure_prepend() {
install -m 0644 ${WORKDIR}/gnome-stock-pixbufs.h ${S}/libgnomeui/pixmaps/gnome-stock-pixbufs.h
}
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta-gnome/packages/gnome/orbit2_2.14.16.bb b/meta-gnome/packages/gnome/orbit2_2.14.16.bb
index 5f6e6f610..42ade84d1 100644
--- a/meta-gnome/packages/gnome/orbit2_2.14.16.bb
+++ b/meta-gnome/packages/gnome/orbit2_2.14.16.bb
@@ -28,19 +28,3 @@ do_configure_prepend() {
install ${WORKDIR}/gtk-doc.make ./
}
-do_stage() {
- oe_libinstall -so -C src/orb libORBit-2 ${STAGING_LIBDIR}
- oe_libinstall -so -C src/services/name libORBitCosNaming-2 ${STAGING_LIBDIR}
- oe_libinstall -so -C src/services/imodule libORBit-imodule-2 ${STAGING_LIBDIR}
- install -m 0644 src/services/name/libname-server-2.a ${STAGING_LIBDIR}/
-
- for dir in orbit orbit/poa orbit/orb-core orbit/util orbit/dynamic; do
- install -d ${STAGING_INCDIR}/orbit-2.0/$dir
- ( cd include/$dir; for i in *.h; do install -m 0644 $i ${STAGING_INCDIR}/orbit-2.0/$dir/$i; done )
- done
-
- install -d ${STAGING_INCDIR}/orbit-2.0/ORBitservices
- install -m 0644 src/services/name/CosNaming.h ${STAGING_INCDIR}/orbit-2.0/ORBitservices/
- install -m 0644 src/services/name/CosNaming_impl.h ${STAGING_INCDIR}/orbit-2.0/ORBitservices/
- install -m 0644 src/services/imodule/orbit-imodule.h ${STAGING_INCDIR}/orbit-2.0/ORBitservices/
-}
diff --git a/meta-gnome/packages/gthumb/gthumb_2.10.11.bb b/meta-gnome/packages/gthumb/gthumb_2.10.11.bb
index 1b957e0a8..2e588d71a 100644
--- a/meta-gnome/packages/gthumb/gthumb_2.10.11.bb
+++ b/meta-gnome/packages/gthumb/gthumb_2.10.11.bb
@@ -7,9 +7,5 @@ DEPENDS = "glib-2.0 gtk+ libbonobo libgnome libgnomeui gnome-vfs libxml2 libglad
inherit gnome pkgconfig
-do_stage () {
- autotools_stage_all
-}
-
FILES_${PN} += "${datadir}/icons"
FILES_${PN}-dbg += "${libdir}/gthumb/modules/.debug" \ No newline at end of file