summaryrefslogtreecommitdiff
path: root/meta/packages/clutter/clutter/enable_tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/clutter/clutter/enable_tests.patch')
-rw-r--r--meta/packages/clutter/clutter/enable_tests.patch44
1 files changed, 14 insertions, 30 deletions
diff --git a/meta/packages/clutter/clutter/enable_tests.patch b/meta/packages/clutter/clutter/enable_tests.patch
index 4a99968fa..854461479 100644
--- a/meta/packages/clutter/clutter/enable_tests.patch
+++ b/meta/packages/clutter/clutter/enable_tests.patch
@@ -4,40 +4,24 @@
tests/test-text.c | 2 +-
3 files changed, 8 insertions(+), 3 deletions(-)
-Index: clutter/tests/Makefile.am
+Index: git/tests/interactive/Makefile.am
===================================================================
---- clutter.orig/tests/Makefile.am 2008-04-25 16:45:17.000000000 +0100
-+++ clutter/tests/Makefile.am 2008-04-25 16:47:12.000000000 +0100
-@@ -1,4 +1,4 @@
--noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
-+bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
- test-actors test-behave test-text test-entry test-project \
- test-perspective test-rotate test-depth \
- test-threads test-timeline test-timeline-dup-frames \
-@@ -14,7 +14,7 @@
- test-cogl-tex-polygon test-stage-read-pixels
+--- git.orig/tests/interactive/Makefile.am 2008-12-18 16:50:45.000000000 +0000
++++ git/tests/interactive/Makefile.am 2008-12-18 16:57:36.000000000 +0000
+@@ -68,7 +68,7 @@
+ AM_CFLAGS = $(CLUTTER_CFLAGS)
+ AM_LDFLAGS = $(CLUTTER_LIBS)
- if X11_TESTS
--noinst_PROGRAMS += test-pixmap
-+bin_PROGRAMS += test-pixmap
- endif
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
- INCLUDES = -I$(top_srcdir)/ -I$(top_builddir)/clutter
-@@ -61,4 +61,9 @@
- test_cogl_offscreen_SOURCES = test-cogl-offscreen.c
- test_stage_read_pixels_SOURCES = test-stage-read-pixels.c
-
-+test_textdir = $(pkgdatadir)
-+test_text_DATA = test-text.c
-+test_actorsdir = $(pkgdatadir)
-+test_actors_DATA = redhand.png
-+
- EXTRA_DIST = redhand.png test-script.json
-Index: clutter/tests/test-actors.c
+ test_interactive_SOURCES = \
+ test-main.c \
+Index: git/tests/interactive/test-actors.c
===================================================================
---- clutter.orig/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
-+++ clutter/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
-@@ -184,7 +184,7 @@
+--- git.orig/tests/interactive/test-actors.c 2008-12-18 16:58:06.000000000 +0000
++++ git/tests/interactive/test-actors.c 2008-12-18 16:58:13.000000000 +0000
+@@ -189,7 +189,7 @@
/* Create a texture from file, then clone in to same resources */
if (i == 0)
{