summaryrefslogtreecommitdiff
path: root/meta/packages/eglibc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/eglibc')
-rw-r--r--meta/packages/eglibc/eglibc-2.12/IO-acquire-lock-fix.patch15
-rw-r--r--meta/packages/eglibc/eglibc-2.12/armv4t-interworking.patch78
-rw-r--r--meta/packages/eglibc/eglibc-2.12/eglibc-svn-arm-lowlevellock-include-tls.patch19
-rw-r--r--meta/packages/eglibc/eglibc-2.12/etc/ld.so.conf2
-rw-r--r--meta/packages/eglibc/eglibc-2.12/generate-supported.mk11
-rw-r--r--meta/packages/eglibc/eglibc-2.12/shorten-build-commands.patch79
-rw-r--r--meta/packages/eglibc/eglibc-initial.inc44
-rw-r--r--meta/packages/eglibc/eglibc-initial_2.12.bb6
-rw-r--r--meta/packages/eglibc/eglibc-package.bbclass381
-rw-r--r--meta/packages/eglibc/eglibc.inc24
-rw-r--r--meta/packages/eglibc/eglibc_2.12.bb97
11 files changed, 0 insertions, 756 deletions
diff --git a/meta/packages/eglibc/eglibc-2.12/IO-acquire-lock-fix.patch b/meta/packages/eglibc/eglibc-2.12/IO-acquire-lock-fix.patch
deleted file mode 100644
index 4d3e0613b..000000000
--- a/meta/packages/eglibc/eglibc-2.12/IO-acquire-lock-fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-import http://sourceware.org/ml/libc-ports/2007-12/msg00000.html
-
-Index: libc/bits/stdio-lock.h
-===================================================================
---- libc.orig/bits/stdio-lock.h 2009-10-28 14:34:19.000000000 -0700
-+++ libc/bits/stdio-lock.h 2009-10-28 14:34:54.000000000 -0700
-@@ -50,6 +50,8 @@ __libc_lock_define_recursive (typedef, _
- _IO_cleanup_region_start ((void (*) (void *)) _IO_funlockfile, (_fp)); \
- _IO_flockfile (_fp)
-
-+# define _IO_acquire_lock_clear_flags2(_fp) _IO_acquire_lock (_fp)
-+
- # define _IO_release_lock(_fp) \
- _IO_funlockfile (_fp); \
- _IO_cleanup_region_end (0)
diff --git a/meta/packages/eglibc/eglibc-2.12/armv4t-interworking.patch b/meta/packages/eglibc/eglibc-2.12/armv4t-interworking.patch
deleted file mode 100644
index 6ab306180..000000000
--- a/meta/packages/eglibc/eglibc-2.12/armv4t-interworking.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-Index: libc/ports/sysdeps/arm/memcpy.S
-===================================================================
---- libc.orig/ports/sysdeps/arm/memcpy.S 2009-09-03 16:12:00.000000000 -0700
-+++ libc/ports/sysdeps/arm/memcpy.S 2009-10-28 12:51:22.000000000 -0700
-@@ -130,7 +130,12 @@ ENTRY(memcpy)
- strcsb r4, [r0], #1
- strcsb ip, [r0]
-
-+#if defined (__ARM_ARCH_4T__) && defined(__THUMB_INTERWORK__)
-+ ldmfd sp!, {r0, r4, lr}
-+ bx lr
-+#else
- ldmfd sp!, {r0, r4, pc}
-+#endif
-
- 9: rsb ip, ip, #4
- cmp ip, #2
-Index: libc/ports/sysdeps/arm/memmove.S
-===================================================================
---- libc.orig/ports/sysdeps/arm/memmove.S 2009-09-03 16:12:00.000000000 -0700
-+++ libc/ports/sysdeps/arm/memmove.S 2009-10-28 12:51:22.000000000 -0700
-@@ -144,7 +144,12 @@ ENTRY(memmove)
- strneb r3, [r0, #-1]!
- strcsb r4, [r0, #-1]!
- strcsb ip, [r0, #-1]
-+#if defined (__ARM_ARCH_4T__) && defined (__THUMB_INTERWORK__)
-+ ldmfd sp!, {r0, r4, lr}
-+ bx lr
-+#else
- ldmfd sp!, {r0, r4, pc}
-+#endif
-
- 9: cmp ip, #2
- ldrgtb r3, [r1, #-1]!
-Index: libc/ports/sysdeps/unix/sysv/linux/arm/clone.S
-===================================================================
---- libc.orig/ports/sysdeps/unix/sysv/linux/arm/clone.S 2009-09-03 16:12:04.000000000 -0700
-+++ libc/ports/sysdeps/unix/sysv/linux/arm/clone.S 2009-10-28 12:51:22.000000000 -0700
-@@ -96,8 +96,14 @@ ENTRY(__clone)
- #endif
- @ pick the function arg and call address off the stack and execute
- ldr r0, [sp, #4]
-+#if defined(__ARM_ARCH_4T__) && defined(__THUMB_INTERWORK__)
-+ ldr ip, [sp], #8
-+ mov lr, pc
-+ bx ip
-+#else
- mov lr, pc
- ldr pc, [sp], #8
-+#endif
-
- @ and we are done, passing the return value through r0
- b PLTJMP(HIDDEN_JUMPTARGET(_exit))
-Index: libc/ports/sysdeps/unix/sysv/linux/arm/sysdep.h
-===================================================================
---- libc.orig/ports/sysdeps/unix/sysv/linux/arm/sysdep.h 2009-09-16 13:58:18.000000000 +0100
-+++ libc/ports/sysdeps/unix/sysv/linux/arm/sysdep.h 2009-11-03 19:17:16.000000000 +0000
-@@ -129,6 +129,11 @@
- DO_RET(lr); \
- 1: .word C_SYMBOL_NAME(rtld_errno) - 0b - 8;
- # else
-+#if defined(__ARM_ARCH_4T__) && defined(__THUMB_INTERWORK__)
-+#define POP_PC ldr lr, [sp], #4; bx lr
-+#else
-+#define POP_PC ldr pc, [sp], #4
-+#endif
- # define SYSCALL_ERROR_HANDLER \
- __local_syscall_error: \
- str lr, [sp, #-4]!; \
-@@ -138,7 +143,7 @@
- rsb r1, r1, #0; \
- str r1, [r0]; \
- mvn r0, #0; \
-- ldr pc, [sp], #4;
-+ POP_PC;
- # endif
- #else
- # define SYSCALL_ERROR_HANDLER /* Nothing here; code in sysdep.S is used. */
diff --git a/meta/packages/eglibc/eglibc-2.12/eglibc-svn-arm-lowlevellock-include-tls.patch b/meta/packages/eglibc/eglibc-2.12/eglibc-svn-arm-lowlevellock-include-tls.patch
deleted file mode 100644
index 99c3fef80..000000000
--- a/meta/packages/eglibc/eglibc-2.12/eglibc-svn-arm-lowlevellock-include-tls.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-In file included from ../nptl/sysdeps/unix/sysv/linux/libc-lowlevellock.c:21:
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c: In function '__lll_lock_wait_private':
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: warning: implicit declaration of function 'THREAD_GETMEM'
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: error: 'THREAD_SELF' undeclared (first use in this function)
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: error: (Each undeclared identifier is reported only once
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: error: for each function it appears in.)
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: error: 'header' undeclared (first use in this function)
-make[4]: *** [/var/tmp/portage/sys-libs/glibc-2.7-r1/work/build-default-armv4l-unknown-linux-gnu-nptl/nptl/rtld-libc-lowlevellock.os] Error 1
-
---- libc/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h.orig
-+++ libc/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h
-@@ -25,6 +25,7 @@
- #include <atomic.h>
- #include <sysdep.h>
- #include <kernel-features.h>
-+#include <tls.h>
-
- #define FUTEX_WAIT 0
- #define FUTEX_WAKE 1
diff --git a/meta/packages/eglibc/eglibc-2.12/etc/ld.so.conf b/meta/packages/eglibc/eglibc-2.12/etc/ld.so.conf
deleted file mode 100644
index dfa65edb8..000000000
--- a/meta/packages/eglibc/eglibc-2.12/etc/ld.so.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-/usr/local/lib
-/usr/X11R6/lib
diff --git a/meta/packages/eglibc/eglibc-2.12/generate-supported.mk b/meta/packages/eglibc/eglibc-2.12/generate-supported.mk
deleted file mode 100644
index d2a28c2dc..000000000
--- a/meta/packages/eglibc/eglibc-2.12/generate-supported.mk
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/usr/bin/make
-
-include $(IN)
-
-all:
- rm -f $(OUT)
- touch $(OUT)
- for locale in $(SUPPORTED-LOCALES); do \
- [ $$locale = true ] && continue; \
- echo $$locale | sed 's,/, ,' >> $(OUT); \
- done
diff --git a/meta/packages/eglibc/eglibc-2.12/shorten-build-commands.patch b/meta/packages/eglibc/eglibc-2.12/shorten-build-commands.patch
deleted file mode 100644
index 57835adcd..000000000
--- a/meta/packages/eglibc/eglibc-2.12/shorten-build-commands.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-Source: http://sourceware.org/ml/libc-alpha/2010-03/msg00064.html
-
-This patch scratches an itch. Each individual gcc command in the
-glibc build is over 1K, which means it takes up a good chunk of my
-terminal. Most of that is include paths. Any version of GCC new
-enough to build glibc supports response files, which were added in
-2005. So use a response file for the static list of include paths.
-Now the build commands are a lot shorter, and easier to use when
-developing glibc.
-
-Tested on x86_64-linux-gnu. Please apply if acceptable.
-
---
-Daniel Jacobowitz
-CodeSourcery
-
-2010-03-30 Daniel Jacobowitz <dan@codesourcery.com>
-
- * Makeconfig (+common-includes): Define.
- (+includes): Use @$(common-objpfx)includes.
- * Makefile (postclean): Remove includes and includes.mk.
- * Makerules ($(common-objpfx)includes.mk): Include and create
- includes.mk. Create includes.
-
-Index: libc/Makeconfig
-===================================================================
---- libc.orig/Makeconfig 2009-10-13 22:55:12.000000000 -0700
-+++ libc/Makeconfig 2010-03-31 16:02:37.120489733 -0700
-@@ -678,9 +678,10 @@ endif # $(+cflags) == ""
- # library source directory, in the include directory, and in the
- # current directory.
- +sysdep-includes = $(addprefix -I,$(+sysdep_dirs))
-++common-includes = $(+sysdep-includes) $(includes) $(sysincludes)
- +includes = -I$(..)include $(if $(subdir),$(objpfx:%/=-I%)) \
-- $(+sysdep-includes) $(includes) \
-- $(patsubst %/,-I%,$(..)) $(libio-include) -I. $(sysincludes)
-+ @$(common-objpfx)includes \
-+ $(patsubst %/,-I%,$(..)) $(libio-include) -I.
-
- # Since libio has several internal header files, we use a -I instead
- # of many little headers in the include directory.
-Index: libc/Makefile
-===================================================================
---- libc.orig/Makefile 2009-12-09 12:06:28.000000000 -0800
-+++ libc/Makefile 2010-03-31 16:02:37.132481508 -0700
-@@ -247,7 +247,7 @@ parent-mostlyclean: common-mostlyclean #
- parent-clean: parent-mostlyclean common-clean
-
- postclean = $(addprefix $(common-objpfx),$(postclean-generated)) \
-- $(addprefix $(objpfx),sysd-dirs sysd-rules) \
-+ $(addprefix $(objpfx),sysd-dirs sysd-rules includes includes.mk) \
- $(addprefix $(objpfx),sysd-sorted soversions.mk soversions.i)
-
- clean: parent-clean
-Index: libc/Makerules
-===================================================================
---- libc.orig/Makerules 2009-12-09 12:06:28.000000000 -0800
-+++ libc/Makerules 2010-03-31 16:02:37.140481645 -0700
-@@ -254,6 +254,20 @@ ifndef sysd-rules-done
- no_deps=t
- endif
-
-+-include $(common-objpfx)includes.mk
-+ifneq ($(+common-includes),$(saved-includes))
-+# Recreate includes.mk (and includes).
-+includes-force = FORCE
-+FORCE:
-+endif
-+$(common-objpfx)includes.mk: $(includes-force)
-+ -@rm -f $@T $(common-objpfx)includesT
-+ for inc in $(+common-includes); do echo "$$inc"; done \
-+ > $(common-objpfx)includesT
-+ mv -f $(common-objpfx)includesT $(common-objpfx)includes
-+ echo 'saved-includes := $(+common-includes)' > $@T
-+ mv -f $@T $@
-+
- define o-iterator-doit
- $(objpfx)%$o: %.S $(before-compile); $$(compile-command.S)
- endef
diff --git a/meta/packages/eglibc/eglibc-initial.inc b/meta/packages/eglibc/eglibc-initial.inc
deleted file mode 100644
index eb765df17..000000000
--- a/meta/packages/eglibc/eglibc-initial.inc
+++ /dev/null
@@ -1,44 +0,0 @@
-SECTION = "libs"
-DEPENDS = "linux-libc-headers virtual/${TARGET_PREFIX}gcc-initial"
-PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
-
-PACKAGES = ""
-PACKAGES_DYNAMIC = ""
-
-do_configure () {
- sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
- chmod +x ${S}/configure
- (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
- find ${S} -name "configure" | xargs touch
- ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
- --prefix=/usr \
- --without-cvs --disable-sanity-checks \
- --with-headers=${STAGING_DIR_TARGET}${includedir} \
- --enable-hacker-mode --enable-addons
-}
-
-do_compile () {
- :
-}
-
-do_install () {
- oe_runmake cross-compiling=yes install_root=${D} \
- includedir='${includedir}' prefix='${prefix}' \
- install-bootstrap-headers=yes install-headers
-
- oe_runmake csu/subdir_lib
- # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
- # so do them by hand. We can tolerate an empty stubs.h for the moment.
- # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
- mkdir -p ${D}${includedir}/gnu/
- touch ${D}${includedir}/gnu/stubs.h
- cp ${S}/include/features.h ${D}${includedir}/features.h
-
- if [ -e ${B}/bits/stdio_lim.h ]; then
- cp ${B}/bits/stdio_lim.h ${D}${includedir}/bits/
- fi
- mkdir -p ${D}${libdir}/
- install -m 644 csu/crt[1in].o ${D}${libdir}
- ${CC} -nostdlib -nostartfiles -shared -x c /dev/null \
- -o ${D}${libdir}/libc.so
-}
diff --git a/meta/packages/eglibc/eglibc-initial_2.12.bb b/meta/packages/eglibc/eglibc-initial_2.12.bb
deleted file mode 100644
index 787c76260..000000000
--- a/meta/packages/eglibc/eglibc-initial_2.12.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require eglibc_${PV}.bb
-require eglibc-initial.inc
-
-do_configure_prepend () {
- unset CFLAGS
-}
diff --git a/meta/packages/eglibc/eglibc-package.bbclass b/meta/packages/eglibc/eglibc-package.bbclass
deleted file mode 100644
index 4e286afa8..000000000
--- a/meta/packages/eglibc/eglibc-package.bbclass
+++ /dev/null
@@ -1,381 +0,0 @@
-#
-# For now, we will skip building of a gcc package if it is a uclibc one
-# and our build is not a uclibc one, and we skip a eglibc one if our build
-# is a uclibc build.
-#
-# See the note in gcc/gcc_3.4.0.oe
-#
-
-inherit qemu
-
-python __anonymous () {
- import bb, re
- uc_os = (re.match('.*uclibc*', bb.data.getVar('TARGET_OS', d, 1)) != None)
- if uc_os:
- raise bb.parse.SkipPackage("incompatible with target %s" %
- bb.data.getVar('TARGET_OS', d, 1))
-}
-
-
-# Binary locales are generated at build time if ENABLE_BINARY_LOCALE_GENERATION
-# is set. The idea is to avoid running localedef on the target (at first boot)
-# to decrease initial boot time and avoid localedef being killed by the OOM
-# killer which used to effectively break i18n on machines with < 128MB RAM.
-
-# default to disabled until qemu works for everyone
-ENABLE_BINARY_LOCALE_GENERATION ?= "0"
-
-# BINARY_LOCALE_ARCHES is a space separated list of regular expressions
-BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc"
-
-# Set this to zero if you don't want ldconfig in the output package
-USE_LDCONFIG ?= "1"
-
-PACKAGES = "eglibc-dbg eglibc catchsegv sln nscd ldd localedef eglibc-utils eglibc-pic eglibc-dev eglibc-doc eglibc-locale libcidn libmemusage libsegfault eglibc-extra-nss eglibc-thread-db eglibc-pcprofile"
-PACKAGES_DYNAMIC = "glibc-gconv-* glibc-charmap-* glibc-localedata-* glibc-binary-localedata-* eglibc-gconv-* eglibc-charmap-* eglibc-localedata-* eglibc-binary-localedata-* locale-base-*"
-
-RPROVIDES_eglibc = "glibc"
-RPROVIDES_eglibc-utils = "glibc-utils"
-RPROVIDES_eglibc-pic = "glibc-pic"
-RPROVIDES_eglibc-dev = "glibc-dev"
-RPROVIDES_eglibc-doc = "glibc-doc"
-RPROVIDES_eglibc-locale = "glibc-locale"
-RPROVIDES_eglibc-extra-nss = "glibc-extra-nss"
-RPROVIDES_eglibc-thread-db = "glibc-thread-db"
-RPROVIDES_eglibc-pcprofile = "glibc-pcprofile"
-RPROVIDES_eglibc-dbg = "glibc-dbg"
-libc_baselibs = "${base_libdir}/libcrypt*.so.* ${base_libdir}/libcrypt-*.so ${base_libdir}/libc*.so.* ${base_libdir}/libc*.so ${base_libdir}/libm*.so.* ${base_libdir}/libm-*.so ${base_libdir}/ld*.so.* ${base_libdir}/ld-*.so ${base_libdir}/libpthread*.so.* ${base_libdir}/libpthread-*.so ${base_libdir}/libresolv*.so.* ${base_libdir}/libresolv-*.so ${base_libdir}/librt*.so.* ${base_libdir}/librt-*.so ${base_libdir}/libutil*.so.* ${base_libdir}/libutil-*.so ${base_libdir}/libnsl*.so.* ${base_libdir}/libnsl-*.so ${base_libdir}/libnss_files*.so.* ${base_libdir}/libnss_files-*.so ${base_libdir}/libnss_compat*.so.* ${base_libdir}/libnss_compat-*.so ${base_libdir}/libnss_dns*.so.* ${base_libdir}/libnss_dns-*.so ${base_libdir}/libdl*.so.* ${base_libdir}/libdl-*.so ${base_libdir}/libanl*.so.* ${base_libdir}/libanl-*.so ${base_libdir}/libBrokenLocale*.so.* ${base_libdir}/libBrokenLocale-*.so"
-
-FILES_${PN} = "${libc_baselibs} ${libexecdir}/* ${@base_conditional('USE_LDCONFIG', '1', '${base_sbindir}/ldconfig', '', d)}"
-FILES_ldd = "${bindir}/ldd"
-FILES_libsegfault = "${base_libdir}/libSegFault*"
-FILES_libcidn = "${base_libdir}/libcidn*.so"
-FILES_libmemusage = "${base_libdir}/libmemusage.so"
-FILES_eglibc-extra-nss = "${base_libdir}/libnss*"
-FILES_sln = "/sbin/sln"
-FILES_eglibc-pic = "${libdir}/*_pic.a ${libdir}/*_pic.map ${libdir}/libc_pic/"
-FILES_eglibc-dev_append += "${bindir}/rpcgen ${libdir}/*.a \
- ${base_libdir}/*.a ${base_libdir}/*.o ${datadir}/aclocal"
-FILES_nscd = "${sbindir}/nscd*"
-FILES_eglibc-utils = "${bindir}/* ${sbindir}/*"
-FILES_eglibc-gconv = "${libdir}/gconv/*"
-FILES_${PN}-dbg += "${libexecdir}/*/.debug ${libdir}/gconv/.debug"
-FILES_catchsegv = "${bindir}/catchsegv"
-RDEPENDS_catchsegv = "libsegfault"
-FILES_eglibc-pcprofile = "${base_libdir}/libpcprofile.so"
-FILES_eglibc-thread-db = "${base_libdir}/libthread_db*"
-FILES_localedef = "${bindir}/localedef"
-RPROVIDES_eglibc-dev += "libc-dev"
-
-DESCRIPTION_sln = "eglibc: create symbolic links between files"
-DESCRIPTION_nscd = "eglibc: name service cache daemon for passwd, group, and hosts"
-DESCRIPTION_eglibc-extra-nss = "eglibc: nis, nisplus and hesiod search services"
-DESCRIPTION_ldd = "eglibc: print shared library dependencies"
-DESCRIPTION_localedef = "eglibc: compile locale definition files"
-DESCRIPTION_eglibc-utils = "eglibc: misc utilities like iconf, local, gencat, tzselect, rpcinfo, ..."
-
-def get_eglibc_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--without-fp"
- return ""
-
-EXTRA_OECONF += "${@get_eglibc_fpu_setting(bb, d)}"
-
-OVERRIDES_append = ":${TARGET_ARCH}-${TARGET_OS}"
-
-do_configure_prepend() {
- sed -e "s#@BASH@#/bin/sh#" -i ${S}/elf/ldd.bash.in
-}
-
-do_install() {
- oe_runmake install_root=${D} install
- for r in ${rpcsvc}; do
- h=`echo $r|sed -e's,\.x$,.h,'`
- install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/
- done
- install -m 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/
- install -d ${D}${libdir}/locale
- make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED"
- # get rid of some broken files...
- for i in ${GLIBC_BROKEN_LOCALES}; do
- grep -v $i ${WORKDIR}/SUPPORTED > ${WORKDIR}/SUPPORTED.tmp
- mv ${WORKDIR}/SUPPORTED.tmp ${WORKDIR}/SUPPORTED
- done
- rm -f ${D}/etc/rpc
- rm -rf ${D}${datadir}/zoneinfo
- rm -rf ${D}${libexecdir}/getconf
-}
-
-TMP_LOCALE="/tmp/locale${libdir}/locale"
-
-locale_base_postinst() {
-#!/bin/sh
-
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-
-rm -rf ${TMP_LOCALE}
-mkdir -p ${TMP_LOCALE}
-if [ -f ${libdir}/locale/locale-archive ]; then
- cp ${libdir}/locale/locale-archive ${TMP_LOCALE}/
-fi
-localedef --inputfile=${datadir}/i18n/locales/%s --charmap=%s --prefix=/tmp/locale %s
-mkdir -p ${libdir}/locale/
-mv ${TMP_LOCALE}/locale-archive ${libdir}/locale/
-rm -rf ${TMP_LOCALE}
-}
-
-locale_base_postrm() {
-#!/bin/sh
-
-rm -rf ${TMP_LOCALE}
-mkdir -p ${TMP_LOCALE}
-if [ -f ${libdir}/locale/locale-archive ]; then
- cp ${libdir}/locale/locale-archive ${TMP_LOCALE}/
-fi
-localedef --delete-from-archive --inputfile=${datadir}/locales/%s --charmap=%s --prefix=/tmp/locale %s
-mv ${TMP_LOCALE}/locale-archive ${libdir}/locale/
-rm -rf ${TMP_LOCALE}
-}
-
-python __anonymous () {
- enabled = bb.data.getVar("ENABLE_BINARY_LOCALE_GENERATION", d, 1)
-
- if enabled and int(enabled):
- import re
-
- target_arch = bb.data.getVar("TARGET_ARCH", d, 1)
- binary_arches = bb.data.getVar("BINARY_LOCALE_ARCHES", d, 1) or ""
-
- for regexp in binary_arches.split(" "):
- r = re.compile(regexp)
-
- if r.match(target_arch):
- depends = bb.data.getVar("DEPENDS", d, 1)
- depends = "%s qemu-native" % depends
- bb.data.setVar("DEPENDS", depends, d)
- bb.data.setVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", "1", d)
- break
-}
-
-do_prep_locale_tree() {
- treedir=${WORKDIR}/locale-tree
- rm -rf $treedir
- mkdir -p $treedir/bin $treedir/lib $treedir/${datadir} $treedir/${libdir}/locale
- cp -pPR ${PKGD}${datadir}/i18n $treedir/${datadir}/i18n
- # unzip to avoid parsing errors
- for i in $treedir/${datadir}/i18n/charmaps/*gz; do
- gunzip $i
- done
- ls -d ${PKGD}${base_libdir}/* | xargs -iBLAH cp -pPR BLAH $treedir/lib
- if [ -f ${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/lib/libgcc_s.* ]; then
- cp -pPR ${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/lib/libgcc_s.* $treedir/lib
- fi
- install -m 0755 ${PKGD}${bindir}/localedef $treedir/bin
-}
-
-do_collect_bins_from_locale_tree() {
- treedir=${WORKDIR}/locale-tree
-
- mkdir -p ${PKGD}${libdir}
- cp -pPR $treedir/${libdir}/locale ${PKGD}${libdir}
-}
-
-python package_do_split_gconvs () {
- import os, re
- if (bb.data.getVar('PACKAGE_NO_GCONV', d, 1) == '1'):
- bb.note("package requested not splitting gconvs")
- return
-
- if not bb.data.getVar('PACKAGES', d, 1):
- return
-
- libdir = bb.data.getVar('libdir', d, 1)
- if not libdir:
- bb.error("libdir not defined")
- return
- datadir = bb.data.getVar('datadir', d, 1)
- if not datadir:
- bb.error("datadir not defined")
- return
-
- gconv_libdir = base_path_join(libdir, "gconv")
- charmap_dir = base_path_join(datadir, "i18n", "charmaps")
- locales_dir = base_path_join(datadir, "i18n", "locales")
- binary_locales_dir = base_path_join(libdir, "locale")
-
- def calc_gconv_deps(fn, pkg, file_regex, output_pattern, group):
- deps = []
- f = open(fn, "r")
- c_re = re.compile('^copy "(.*)"')
- i_re = re.compile('^include "(\w+)".*')
- for l in f.readlines():
- m = c_re.match(l) or i_re.match(l)
- if m:
- dp = legitimize_package_name('eglibc-gconv-%s' % m.group(1))
- if not dp in deps:
- deps.append(dp)
- f.close()
- if deps != []:
- bb.data.setVar('RDEPENDS_%s' % pkg, " ".join(deps), d)
- bb.data.setVar('RPROVIDES_%s' % pkg, pkg.replace('eglibc', 'glibc'), d)
-
- do_split_packages(d, gconv_libdir, file_regex='^(.*)\.so$', output_pattern='eglibc-gconv-%s', description='gconv module for character set %s', hook=calc_gconv_deps, extra_depends='eglibc-gconv')
-
- def calc_charmap_deps(fn, pkg, file_regex, output_pattern, group):
- deps = []
- f = open(fn, "r")
- c_re = re.compile('^copy "(.*)"')
- i_re = re.compile('^include "(\w+)".*')
- for l in f.readlines():
- m = c_re.match(l) or i_re.match(l)
- if m:
- dp = legitimize_package_name('eglibc-charmap-%s' % m.group(1))
- if not dp in deps:
- deps.append(dp)
- f.close()
- if deps != []:
- bb.data.setVar('RDEPENDS_%s' % pkg, " ".join(deps), d)
- bb.data.setVar('RPROVIDES_%s' % pkg, pkg.replace('eglibc', 'glibc'), d)
-
- do_split_packages(d, charmap_dir, file_regex='^(.*)\.gz$', output_pattern='eglibc-charmap-%s', description='character map for %s encoding', hook=calc_charmap_deps, extra_depends='')
-
- def calc_locale_deps(fn, pkg, file_regex, output_pattern, group):
- deps = []
- f = open(fn, "r")
- c_re = re.compile('^copy "(.*)"')
- i_re = re.compile('^include "(\w+)".*')
- for l in f.readlines():
- m = c_re.match(l) or i_re.match(l)
- if m:
- dp = legitimize_package_name('eglibc-localedata-%s' % m.group(1))
- if not dp in deps:
- deps.append(dp)
- f.close()
- if deps != []:
- bb.data.setVar('RDEPENDS_%s' % pkg, " ".join(deps), d)
- bb.data.setVar('RPROVIDES_%s' % pkg, pkg.replace('eglibc', 'glibc'), d)
-
- do_split_packages(d, locales_dir, file_regex='(.*)', output_pattern='eglibc-localedata-%s', description='locale definition for %s', hook=calc_locale_deps, extra_depends='')
- bb.data.setVar('PACKAGES', bb.data.getVar('PACKAGES', d) + ' eglibc-gconv', d)
-
- supported = bb.data.getVar('GLIBC_GENERATE_LOCALES', d, 1)
- if not supported or supported == "all":
- f = open(base_path_join(bb.data.getVar('WORKDIR', d, 1), "SUPPORTED"), "r")
- supported = f.readlines()
- f.close()
- else:
- supported = supported.split()
- supported = map(lambda s:s.replace(".", " ") + "\n", supported)
-
- dot_re = re.compile("(.*)\.(.*)")
-
- # Collate the locales by base and encoding
- encodings = {}
- for l in supported:
- l = l[:-1]
- (locale, charset) = l.split(" ")
- m = dot_re.match(locale)
- if m:
- locale = m.group(1)
- if not encodings.has_key(locale):
- encodings[locale] = []
- encodings[locale].append(charset)
-
- def output_locale_source(name, locale, encoding):
- pkgname = 'locale-base-' + legitimize_package_name(name)
-
- bb.data.setVar('RDEPENDS_%s' % pkgname, 'localedef eglibc-localedata-%s eglibc-charmap-%s' % (legitimize_package_name(locale), legitimize_package_name(encoding)), d)
- rprovides = 'virtual-locale-%s' % legitimize_package_name(name)
- m = re.match("(.*)_(.*)", name)
- if m:
- rprovides += ' virtual-locale-%s' % m.group(1)
- bb.data.setVar('RPROVIDES_%s' % pkgname, rprovides, d)
- bb.data.setVar('PACKAGES', '%s %s' % (pkgname, bb.data.getVar('PACKAGES', d, 1)), d)
- bb.data.setVar('ALLOW_EMPTY_%s' % pkgname, '1', d)
- bb.data.setVar('pkg_postinst_%s' % pkgname, bb.data.getVar('locale_base_postinst', d, 1) % (locale, encoding, locale), d)
- bb.data.setVar('pkg_postrm_%s' % pkgname, bb.data.getVar('locale_base_postrm', d, 1) % (locale, encoding, locale), d)
-
- def output_locale_binary(name, locale, encoding):
- qemu = qemu_target_binary(d) + " -s 1048576"
- kernel_ver = bb.data.getVar("OLDEST_KERNEL", d, 1)
- if kernel_ver:
- qemu += " -r %s" % (kernel_ver)
- pkgname = 'locale-base-' + legitimize_package_name(name)
- m = re.match("(.*)\.(.*)", name)
- if m:
- eglibc_name = "%s.%s" % (m.group(1), m.group(2).lower().replace("-",""))
- else:
- eglibc_name = name
- bb.data.setVar('RDEPENDS_%s' % pkgname, legitimize_package_name('eglibc-binary-localedata-%s' % eglibc_name), d)
- bb.data.setVar('RPROVIDES_%s' % pkgname, 'glibc-binary-localedata-%s' % eglibc_name, d)
- rprovides = 'virtual-locale-%s' % legitimize_package_name(name)
- m = re.match("(.*)_(.*)", name)
- if m:
- rprovides += ' virtual-locale-%s' % m.group(1)
- bb.data.setVar('RPROVIDES_%s' % pkgname, rprovides, d)
- bb.data.setVar('ALLOW_EMPTY_%s' % pkgname, '1', d)
- bb.data.setVar('PACKAGES', '%s %s' % (pkgname, bb.data.getVar('PACKAGES', d, 1)), d)
-
- treedir = base_path_join(bb.data.getVar("WORKDIR", d, 1), "locale-tree")
- ldlibdir = "%s/lib" % treedir
- path = bb.data.getVar("PATH", d, 1)
- i18npath = base_path_join(treedir, datadir, "i18n")
-
- localedef_opts = "--force --old-style --no-archive --prefix=%s --inputfile=%s/i18n/locales/%s --charmap=%s %s" % (treedir, datadir, locale, encoding, name)
- cmd = "PATH=\"%s\" I18NPATH=\"%s\" %s -L %s -E LD_LIBRARY_PATH=%s %s/bin/localedef %s" % (path, i18npath, qemu, treedir, ldlibdir, treedir, localedef_opts)
- bb.note("generating locale %s (%s)" % (locale, encoding))
- if os.system(cmd):
- raise bb.build.FuncFailed("localedef returned an error (command was %s)." % cmd)
-
- def output_locale(name, locale, encoding):
- use_bin = bb.data.getVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", d, 1)
- if use_bin:
- output_locale_binary(name, locale, encoding)
- else:
- output_locale_source(name, locale, encoding)
-
- use_bin = bb.data.getVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", d, 1)
- if use_bin:
- bb.note("preparing tree for binary locale generation")
- bb.build.exec_func("do_prep_locale_tree", d)
-
- # Reshuffle names so that UTF-8 is preferred over other encodings
- non_utf8 = []
- for l in encodings.keys():
- if len(encodings[l]) == 1:
- output_locale(l, l, encodings[l][0])
- if encodings[l][0] != "UTF-8":
- non_utf8.append(l)
- else:
- if "UTF-8" in encodings[l]:
- output_locale(l, l, "UTF-8")
- encodings[l].remove("UTF-8")
- else:
- non_utf8.append(l)
- for e in encodings[l]:
- output_locale('%s.%s' % (l, e), l, e)
-
- if non_utf8 != []:
- bb.note("the following locales are supported only in legacy encodings:")
- bb.note(" " + " ".join(non_utf8))
-
- use_bin = bb.data.getVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", d, 1)
- if use_bin:
- bb.note("collecting binary locales from locale tree")
- bb.build.exec_func("do_collect_bins_from_locale_tree", d)
- do_split_packages(d, binary_locales_dir, file_regex='(.*)', output_pattern='eglibc-binary-localedata-%s', description='binary locale definition for %s', extra_depends='', allow_dirs=True)
- else:
- bb.note("generation of binary locales disabled. this may break i18n!")
-
-}
-
-# We want to do this indirection so that we can safely 'return'
-# from the called function even though we're prepending
-python populate_packages_prepend () {
- if bb.data.getVar('DEBIAN_NAMES', d, 1):
- bb.data.setVar('PKG_eglibc', 'libc6', d)
- bb.data.setVar('PKG_eglibc-dev', 'libc6-dev', d)
- bb.build.exec_func('package_do_split_gconvs', d)
-}
diff --git a/meta/packages/eglibc/eglibc.inc b/meta/packages/eglibc/eglibc.inc
deleted file mode 100644
index 66bb90e83..000000000
--- a/meta/packages/eglibc/eglibc.inc
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Embedded GNU C Library"
-HOMEPAGE = "http://www.eglibc.org/home"
-SECTION = "libs"
-PRIORITY = "required"
-LICENSE = "LGPL"
-INC_PR = "r11"
-# nptl needs unwind support in gcc, which can't be built without glibc.
-DEPENDS = "virtual/${TARGET_PREFIX}gcc-intermediate linux-libc-headers"
-#this leads to circular deps, so lets not add it yet
-#RDEPENDS_ldd += " bash"
-# nptl needs libgcc but dlopens it, so our shlibs code doesn't detect this
-#RDEPENDS_${PN} += "${@['','libgcc']['nptl' in '${GLIBC_ADDONS}']}"
-PROVIDES = "virtual/libc virtual/${TARGET_PREFIX}libc-for-gcc"
-PROVIDES += "virtual/libintl virtual/libiconv"
-inherit autotools
-
-LEAD_SONAME = "libc.so"
-
-GLIBC_EXTRA_OECONF ?= ""
-INHIBIT_DEFAULT_DEPS = "1"
-
-ARM_INSTRUCTION_SET = "arm"
-
-PACKAGES = "glibc catchsegv sln nscd ldd localedef glibc-utils glibc-dev glibc-doc glibc-locale libsegfault glibc-extra-nss glibc-thread-db glibc-pcprofile"
diff --git a/meta/packages/eglibc/eglibc_2.12.bb b/meta/packages/eglibc/eglibc_2.12.bb
deleted file mode 100644
index a21498070..000000000
--- a/meta/packages/eglibc/eglibc_2.12.bb
+++ /dev/null
@@ -1,97 +0,0 @@
-require eglibc.inc
-
-DEPENDS += "gperf-native"
-FILESPATHPKG =. "eglibc-svn:"
-PR = "r0"
-SRCREV="10809"
-EGLIBC_BRANCH="eglibc-2_12"
-SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
- file://eglibc-svn-arm-lowlevellock-include-tls.patch \
- file://IO-acquire-lock-fix.patch \
- file://shorten-build-commands.patch \
- file://etc/ld.so.conf \
- file://generate-supported.mk"
-S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
-B = "${WORKDIR}/build-${TARGET_SYS}"
-
-PACKAGES_DYNAMIC = "libc6*"
-RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
-PROVIDES_${PN}-dbg = "glibc-dbg"
-
-# the -isystem in bitbake.conf screws up glibc do_stage
-BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
-TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
-
-GLIBC_ADDONS ?= "ports,nptl,libidn"
-
-GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
-
-#
-# For now, we will skip building of a gcc package if it is a uclibc one
-# and our build is not a uclibc one, and we skip a glibc one if our build
-# is a uclibc build.
-#
-# See the note in gcc/gcc_3.4.0.oe
-#
-
-python __anonymous () {
- import bb, re
- uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
- if uc_os:
- raise bb.parse.SkipPackage("incompatible with target %s" %
- bb.data.getVar('TARGET_OS', d, 1))
-}
-
-EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
- --without-cvs --disable-profile --disable-debug --without-gd \
- --enable-clocale=gnu \
- --enable-add-ons=${GLIBC_ADDONS},ports \
- --with-headers=${STAGING_INCDIR} \
- --without-selinux \
- ${GLIBC_EXTRA_OECONF}"
-
-EXTRA_OECONF += "${@get_eglibc_fpu_setting(bb, d)}"
-
-do_unpack_append() {
- bb.build.exec_func('do_move_ports', d)
-}
-
-do_move_ports() {
- if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
- rm -rf ${S}/ports
- mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
- fi
-}
-
-do_configure () {
-# override this function to avoid the autoconf/automake/aclocal/autoheader
-# calls for now
-# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
-# version check and doesn't really help with anything
- if [ -z "`which rpcgen`" ]; then
- echo "rpcgen not found. Install glibc-devel."
- exit 1
- fi
- (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
- find ${S} -name "configure" | xargs touch
- CPPFLAGS="" oe_runconf
-}
-
-rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
- yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
- rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
-
-do_compile () {
- # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
- unset LDFLAGS
- base_do_compile
- (
- cd ${S}/sunrpc/rpcsvc
- for r in ${rpcsvc}; do
- h=`echo $r|sed -e's,\.x$,.h,'`
- rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
- done
- )
-}
-
-require eglibc-package.bbclass