summaryrefslogtreecommitdiff
path: root/meta/packages/glib-2.0/glib-2.0-2.24.1
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/glib-2.0/glib-2.0-2.24.1')
-rw-r--r--meta/packages/glib-2.0/glib-2.0-2.24.1/60_wait-longer-for-threads-to-die.patch29
-rw-r--r--meta/packages/glib-2.0/glib-2.0-2.24.1/configure-libtool.patch34
-rw-r--r--meta/packages/glib-2.0/glib-2.0-2.24.1/gatomic-proper-pointer-get-cast.patch37
-rw-r--r--meta/packages/glib-2.0/glib-2.0-2.24.1/glib-gettextize-dir.patch19
4 files changed, 0 insertions, 119 deletions
diff --git a/meta/packages/glib-2.0/glib-2.0-2.24.1/60_wait-longer-for-threads-to-die.patch b/meta/packages/glib-2.0/glib-2.0-2.24.1/60_wait-longer-for-threads-to-die.patch
deleted file mode 100644
index 1676b3e25..000000000
--- a/meta/packages/glib-2.0/glib-2.0-2.24.1/60_wait-longer-for-threads-to-die.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-# copy from OE, said to borrow from Ubuntu. Not in glib-2.0 upstream yet. Add for sanity.
-#
-# by Kevin Tian <kevin.tian@intel.com>, 06/25/2010
---- glib/tests/threadpool-test.c.old 2008-02-12 06:11:21.000000000 +0100
-+++ glib/tests/threadpool-test.c 2008-02-12 06:11:52.000000000 +0100
-@@ -5,8 +5,8 @@
-
- #include <glib.h>
-
--#define DEBUG_MSG(x)
--/* #define DEBUG_MSG(args) g_printerr args ; g_printerr ("\n"); */
-+/* #define DEBUG_MSG(x) */
-+#define DEBUG_MSG(args) g_printerr args ; g_printerr ("\n");
-
- #define WAIT 5 /* seconds */
- #define MAX_THREADS 10
-@@ -124,10 +124,10 @@
- DEBUG_MSG (("[unused] stopping unused threads"));
- g_thread_pool_stop_unused_threads ();
-
-- DEBUG_MSG (("[unused] waiting ONE second for threads to die"));
-+ DEBUG_MSG (("[unused] waiting FIVE second for threads to die"));
-
- /* Some time for threads to die. */
-- g_usleep (G_USEC_PER_SEC);
-+ g_usleep (5 * G_USEC_PER_SEC);
-
- DEBUG_MSG (("[unused] stopped idle threads, %d remain, %d threads still exist",
- g_thread_pool_get_num_unused_threads (),
diff --git a/meta/packages/glib-2.0/glib-2.0-2.24.1/configure-libtool.patch b/meta/packages/glib-2.0/glib-2.0-2.24.1/configure-libtool.patch
deleted file mode 100644
index 3ba79b898..000000000
--- a/meta/packages/glib-2.0/glib-2.0-2.24.1/configure-libtool.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-# Poky renames libtool to $host_alias-libtool.
-# ./$host_alias-libtool isn't created until after configure runs with libtool >= 2.2.2
-# so we can't call # it at this point. We can safely assume a version is available
-# from PATH though
-
---- glib-2.12.10/configure.in.orig 2006-06-05 13:34:08.000000000 +0100
-+++ glib-2.12.10/configure.in 2006-06-05 13:34:36.000000000 +0100
-@@ -1174,7 +1174,7 @@
- G_MODULE_LDFLAGS=
- else
- export SED
-- G_MODULE_LDFLAGS=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
-+ G_MODULE_LDFLAGS=`($host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
- fi
- dnl G_MODULE_IMPL= don't reset, so cmd-line can override
- G_MODULE_NEED_USCORE=0
-@@ -1265,7 +1265,7 @@
- LDFLAGS="$LDFLAGS $G_MODULE_LDFLAGS"
- dnl *** check for OSF1/5.0 RTLD_GLOBAL brokenness
- echo "void glib_plugin_test(void) { }" > plugin.c
-- ${SHELL} ./libtool --mode=compile ${CC} -shared \
-+ ${SHELL} $host_alias-libtool --mode=compile ${CC} -shared \
- -export-dynamic -o plugin.o plugin.c 2>&1 >/dev/null
- AC_CACHE_CHECK([for RTLD_GLOBAL brokenness],
- glib_cv_rtldglobal_broken,[
-@@ -1339,7 +1339,7 @@
-
- AC_MSG_CHECKING(for the suffix of shared libraries)
- export SED
--shrext_cmds=`./libtool --config | grep '^shrext_cmds='`
-+shrext_cmds=`$host_alias-libtool --config | grep '^shrext_cmds='`
- eval $shrext_cmds
- module=yes eval std_shrext=$shrext_cmds
- # chop the initial dot
diff --git a/meta/packages/glib-2.0/glib-2.0-2.24.1/gatomic-proper-pointer-get-cast.patch b/meta/packages/glib-2.0/glib-2.0-2.24.1/gatomic-proper-pointer-get-cast.patch
deleted file mode 100644
index 1f3920f03..000000000
--- a/meta/packages/glib-2.0/glib-2.0-2.24.1/gatomic-proper-pointer-get-cast.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-# handle cast warning. borrow from OE, but updated with a better fix from glib
-# developing tree.
-#
-# by Kevin Tian <kevin.tian@intel.com>, 06/25/2010
-commit bf2719c815d719d1899b4bdb1b81ff6798471094
-Author: Lars Ellenberg <lars.ellenberg@linbit.com>
-Date: Thu Apr 15 19:03:05 2010 +0200
-
- Cast to volatile to avoid warnings from -Wcast-qual
-
- https://bugzilla.gnome.org/show_bug.cgi?id=457641
-
-diff --git a/glib/gatomic.h b/glib/gatomic.h
-index 7d9c318..22b28d9 100644
---- a/glib/gatomic.h
-+++ b/glib/gatomic.h
-@@ -64,16 +64,16 @@ void g_atomic_pointer_set (volatile gpointer G_GNUC_MAY_ALI
- #else
- # define g_atomic_int_get(atomic) \
- ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gint) ? 1 : -1]), \
-- (g_atomic_int_get) ((volatile gint G_GNUC_MAY_ALIAS *) (void *) (atomic)))
-+ (g_atomic_int_get) ((volatile gint G_GNUC_MAY_ALIAS *) (volatile void *) (atomic)))
- # define g_atomic_int_set(atomic, newval) \
- ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gint) ? 1 : -1]), \
-- (g_atomic_int_set) ((volatile gint G_GNUC_MAY_ALIAS *) (void *) (atomic), (newval)))
-+ (g_atomic_int_set) ((volatile gint G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
- # define g_atomic_pointer_get(atomic) \
- ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
-- (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (void *) (atomic)))
-+ (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic)))
- # define g_atomic_pointer_set(atomic, newval) \
- ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
-- (g_atomic_pointer_set) ((volatile gpointer G_GNUC_MAY_ALIAS *) (void *) (atomic), (newval)))
-+ (g_atomic_pointer_set) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
- #endif /* G_ATOMIC_OP_MEMORY_BARRIER_NEEDED */
-
- #define g_atomic_int_inc(atomic) (g_atomic_int_add ((atomic), 1))
diff --git a/meta/packages/glib-2.0/glib-2.0-2.24.1/glib-gettextize-dir.patch b/meta/packages/glib-2.0/glib-2.0-2.24.1/glib-gettextize-dir.patch
deleted file mode 100644
index c44e49155..000000000
--- a/meta/packages/glib-2.0/glib-2.0-2.24.1/glib-gettextize-dir.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-# an very old patch cherry-picked in every glib-2.0 patch directory. The earliest container
-# for it is 2.6.5 in OE. The earliest commit for it is c8e5702127e507e82e6f68a4b8c546803accea9d
-# in OE side which ports from previous bitkeeper SCM. In OE side it's only used til 2.12.4.
-#
-# keep it since it's always cleaner to not hardcode destination path. Use @datadir@ is more
-# portable here. mark for upstream
-#
-# by Kevin Tian <kevin.tian@intel.com>, 06/25/2010
---- glib-2.10.3/glib-gettextize.in.old 2006-06-21 12:46:45.000000000 +0100
-+++ glib-2.10.3/glib-gettextize.in 2006-06-21 12:48:14.000000000 +0100
-@@ -49,7 +49,7 @@
- ;;
- esac
-
--gettext_dir=$prefix/share/glib-2.0/gettext
-+gettext_dir=@datadir@/glib-2.0/gettext
-
- while test $# -gt 0; do
- case "$1" in