summaryrefslogtreecommitdiff
path: root/meta/packages/hostap/hostap-conf_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/hostap/hostap-conf_1.0.bb')
-rw-r--r--meta/packages/hostap/hostap-conf_1.0.bb21
1 files changed, 20 insertions, 1 deletions
diff --git a/meta/packages/hostap/hostap-conf_1.0.bb b/meta/packages/hostap/hostap-conf_1.0.bb
index 1b0edf19c..b95b3dd2c 100644
--- a/meta/packages/hostap/hostap-conf_1.0.bb
+++ b/meta/packages/hostap/hostap-conf_1.0.bb
@@ -3,13 +3,32 @@ SECTION = "kernel/modules"
PRIORITY = "optional"
LICENSE = "GPL"
PACKAGE_ARCH = "all"
-PR = "r4"
+PR = "r8"
SRC_URI = "file://hostap_cs.conf \
+ file://hostap_cs.modalias \
file://hostap_cs.conf-upstream"
+do_compile() {
+}
+
do_install() {
install -d ${D}${sysconfdir}/pcmcia
+ install -d ${D}${sysconfdir}/modutils
+
install -m 0644 ${WORKDIR}/hostap_cs.conf-upstream ${D}${sysconfdir}/pcmcia/hostap_cs.conf
cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
+
+ install -m 0644 ${WORKDIR}/hostap_cs.modalias ${D}${sysconfdir}/modutils/hostap_cs.conf
+}
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
}