summaryrefslogtreecommitdiff
path: root/meta/packages/libpcap/libpcap_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libpcap/libpcap_1.0.0.bb')
-rw-r--r--meta/packages/libpcap/libpcap_1.0.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/packages/libpcap/libpcap_1.0.0.bb b/meta/packages/libpcap/libpcap_1.0.0.bb
new file mode 100644
index 000000000..edd9706b1
--- /dev/null
+++ b/meta/packages/libpcap/libpcap_1.0.0.bb
@@ -0,0 +1,19 @@
+require libpcap.inc
+
+PR = "r0"
+
+SRC_URI += "file://config-fixes.patch;patch=1 \
+ file://aclocal.patch;patch=1 \
+ file://ieee80215-arphrd.patch;patch=1 \
+ file://ldflags.patch;patch=1"
+
+#
+# make install doesn't cover the shared lib
+# make install-shared is just broken (no symlinks)
+#
+do_install_prepend () {
+ install -d ${D}${libdir}
+ install -d ${D}${bindir}
+ oe_runmake install-shared DESTDIR=${D}
+ oe_libinstall -a -so libpcap ${D}${libdir}
+}