summaryrefslogtreecommitdiff
path: root/meta/packages/libxml/libxml2_2.6.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libxml/libxml2_2.6.26.bb')
-rw-r--r--meta/packages/libxml/libxml2_2.6.26.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/libxml/libxml2_2.6.26.bb b/meta/packages/libxml/libxml2_2.6.26.bb
new file mode 100644
index 000000000..e330050b8
--- /dev/null
+++ b/meta/packages/libxml/libxml2_2.6.26.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "GNOME XML Parser library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "r4"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
+ file://no-testapi.patch;patch=1"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n --without-schemas --without-schematron --with-reader"
+
+export LDFLAGS += "-ldl"
+
+do_stage() {
+ autotools_stage_all
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+ #this is need it by php during its install
+ install -m 0755 xml2-config ${STAGING_BINDIR}
+}
+
+python populate_packages_prepend () {
+ # autonamer would call this libxml2-2, but we don't want that
+ if bb.data.getVar('DEBIAN_NAMES', d, 1):
+ bb.data.setVar('PKG_libxml2', 'libxml2', d)
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/*-config"
+FILES_${PN}-utils += "${bindir}/*"