summaryrefslogtreecommitdiff
path: root/meta/packages/libxsettings-client
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libxsettings-client')
-rw-r--r--meta/packages/libxsettings-client/files/MIT-style-license22
-rw-r--r--meta/packages/libxsettings-client/libxsettings-client_0.10.bb20
2 files changed, 39 insertions, 3 deletions
diff --git a/meta/packages/libxsettings-client/files/MIT-style-license b/meta/packages/libxsettings-client/files/MIT-style-license
new file mode 100644
index 000000000..628de9830
--- /dev/null
+++ b/meta/packages/libxsettings-client/files/MIT-style-license
@@ -0,0 +1,22 @@
+/*
+ * Copyright © 2001 Red Hat, Inc.
+ *
+ * Permission to use, copy, modify, distribute, and sell this software and its
+ * documentation for any purpose is hereby granted without fee, provided that
+ * the above copyright notice appear in all copies and that both that
+ * copyright notice and this permission notice appear in supporting
+ * documentation, and that the name of Red Hat not be used in advertising or
+ * publicity pertaining to distribution of the software without specific,
+ * written prior permission. Red Hat makes no representations about the
+ * suitability of this software for any purpose. It is provided "as is"
+ * without express or implied warranty.
+ *
+ * RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL RED HAT
+ * BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION
+ * OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+ * CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ * Author: Owen Taylor, Red Hat, Inc.
+ */
diff --git a/meta/packages/libxsettings-client/libxsettings-client_0.10.bb b/meta/packages/libxsettings-client/libxsettings-client_0.10.bb
index eba2df18b..ecd6d181e 100644
--- a/meta/packages/libxsettings-client/libxsettings-client_0.10.bb
+++ b/meta/packages/libxsettings-client/libxsettings-client_0.10.bb
@@ -1,16 +1,30 @@
DESCRIPTION = "Common code for XSETTINGS"
+HOMEPAGE = "http://matchbox-project.org/sources/optional-dependencies/"
+BUGTRACKER = "http://bugzilla.openedhand.com/"
SECTION = "x/libs"
-LICENSE = "BSD-X"
+LICENSE = "MIT-style"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+ file://xsettings-client.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+ file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
PRIORITY = "optional"
DEPENDS = "virtual/libx11"
-PR = "r2"
+PR = "r3"
headers = "xsettings-common.h xsettings-client.h"
SRC_URI = "http://projects.o-hand.com/matchbox/sources/optional-dependencies/Xsettings-client-0.10.tar.gz \
- file://link-x11.patch;patch=1"
+ file://MIT-style-license \
+ file://link-x11.patch;apply=yes"
S = "${WORKDIR}/Xsettings-client-0.10"
inherit autotools gettext
+
+do_configure_prepend() {
+ # This package doesn't ship with its own COPYING file and
+ # autotools will install a GPLv2 one instead of the actual MIT-style license here.
+ # Add the correct license here to avoid confusion.
+ cp -f ${WORKDIR}/MIT-style-license ${S}/COPYING
+}
+