summaryrefslogtreecommitdiff
path: root/meta/packages/matchbox-sato
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-sato')
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato_0.1.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
index e2f4aeb82..b8d6d7151 100644
--- a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
+++ b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -3,11 +3,18 @@ LICENSE = "GPL"
SECTION = "x11"
RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts"
RCONFLICTS = "matchbox-common"
-PR = "r20"
+PR = "r21"
SRC_URI = "file://etc file://matchbox-session"
S = ${WORKDIR}
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "x-session-manager"
+ALTERNATIVE_LINK = "${bindir}/x-session-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
do_install() {
install -d ${D}/${bindir}
install -m 0755 ${S}/matchbox-session ${D}/${bindir}