summaryrefslogtreecommitdiff
path: root/meta/packages/mutter/mutter_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/mutter/mutter_git.bb')
-rw-r--r--meta/packages/mutter/mutter_git.bb50
1 files changed, 3 insertions, 47 deletions
diff --git a/meta/packages/mutter/mutter_git.bb b/meta/packages/mutter/mutter_git.bb
index 7352cf8a9..b41bf1e50 100644
--- a/meta/packages/mutter/mutter_git.bb
+++ b/meta/packages/mutter/mutter_git.bb
@@ -1,11 +1,7 @@
-SECTION = "x11/wm"
-DESCRIPTION = "Metacity is the boring window manager for the adult in you. Mutter is metacity + clutter."
-LICENSE = "GPLv2"
-DEPENDS = "startup-notification gtk+ gconf clutter-1.0 gdk-pixbuf-csource-native intltool glib-2.0-native"
-# gobject-introspection
-PR = "r18"
+require mutter.inc
+
PV = "2.28.1+git${SRCPV}"
-inherit gnome update-alternatives
+PR = "r18"
# Gnome is the upstream but moblin is under more active development atm
# git://git.gnome.org/mutter.git;protocol=git;branch=master
@@ -19,43 +15,3 @@ SRC_URI = "git://git.moblin.org/mutter.git;protocol=git;branch=master \
"
S = "${WORKDIR}/git"
-ALTERNATIVE_NAME = "x-window-manager"
-ALTERNATIVE_LINK = "${bindir}/x-window-manager"
-ALTERNATIVE_PATH = "${bindir}/mutter"
-ALTERNATIVE_PRIORITY = "11"
-
-EXTRA_OECONF += "--disable-verbose \
- --disable-xinerama \
- --without-introspection \
- --with-clutter"
-
-#RDEPENDS_${PN} = "zenity"
-
-FILES_${PN} += "${datadir}/themes ${libdir}/mutter/plugins/*.so ${datadir}/gnome/wm-properties/"
-FILES_${PN}-dbg += "${libdir}/mutter/plugins/.debug/*"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include"
-export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS} -L${STAGING_LIBDIR_NATIVE} -lglib-2.0"
-
-do_configure_prepend () {
- echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make
-}
-
-do_stage () {
- autotools_stage_all
-}
-
-pkg_postinst_${PN} () {
-#!/bin/sh -e
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-
-. ${sysconfdir}/init.d/functions
-
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/mutter/general/clutter_plugins '[default]'
-
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/mutter/general/compositing_manager true
-}
-