summaryrefslogtreecommitdiff
path: root/meta/packages/neon/neon_0.28.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/neon/neon_0.28.1.bb')
-rw-r--r--meta/packages/neon/neon_0.28.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/packages/neon/neon_0.28.1.bb b/meta/packages/neon/neon_0.28.1.bb
new file mode 100644
index 000000000..d99b9a64a
--- /dev/null
+++ b/meta/packages/neon/neon_0.28.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "zlib libxml2 expat time gnutls"
+
+SRC_URI = "http://www.webdav.org/${PN}/${P}.tar.gz \
+ file://pkgconfig.patch;patch=1"
+
+inherit autotools binconfig lib_package pkgconfig
+
+EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
+
+do_stage () {
+ autotools_stage_all
+}