summaryrefslogtreecommitdiff
path: root/meta/packages/opkg/opkg.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/opkg/opkg.inc')
-rw-r--r--meta/packages/opkg/opkg.inc13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/packages/opkg/opkg.inc b/meta/packages/opkg/opkg.inc
index d82f6d53f..1d1cb5c26 100644
--- a/meta/packages/opkg/opkg.inc
+++ b/meta/packages/opkg/opkg.inc
@@ -4,6 +4,8 @@ DESCRIPTION_update-alternatives-cworth = "Update alternatives"
SECTION = "base"
LICENSE = "GPL"
DEPENDS = "curl gpgme"
+DEPENDS_virtclass-native = "curl-native"
+DEPENDS_virtclass-nativesdk = "curl-nativesdk"
PV = "0.0+svnr${SRCREV}"
PE = "1"
@@ -14,9 +16,20 @@ SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
S = "${WORKDIR}/trunk"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/opkg"
+
# Werror gives all kinds bounds issuses with gcc 4.3.3
do_configure_prepend() {
sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
}
inherit autotools_stage pkgconfig
+
+target_libdir := "${libdir}"
+EXTRA_OECONF_virtclass-native = "--with-opkglibdir=${target_libdir} --disable-gpg"
+EXTRA_OECONF_virtclass-nativesdk = "--with-opkglibdir=${target_libdir} --disable-gpg"
+
+#PROVIDES_append_virtclass-native = "virtual/update-alternatives-native"
+#RPROVIDES_${PN} += "update-alternatives-native"
+
+BBCLASSEXTEND = "native nativesdk"