summaryrefslogtreecommitdiff
path: root/meta/packages/oprofile/oprofile_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/oprofile/oprofile_cvs.bb')
-rw-r--r--meta/packages/oprofile/oprofile_cvs.bb22
1 files changed, 3 insertions, 19 deletions
diff --git a/meta/packages/oprofile/oprofile_cvs.bb b/meta/packages/oprofile/oprofile_cvs.bb
index cab065a07..e848bacf4 100644
--- a/meta/packages/oprofile/oprofile_cvs.bb
+++ b/meta/packages/oprofile/oprofile_cvs.bb
@@ -1,5 +1,5 @@
PV = "0.9.3+cvs${SRCDATE}"
-PR = "r1"
+PR = "r4"
SECTION = "devel"
DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
of profiling all running code at low overhead."
@@ -10,14 +10,13 @@ RRECOMMENDS = "kernel-vmlinux"
SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \
file://opstart.patch;patch=1 \
+ file://fix_debug_search.patch;patch=1;pnum=0 \
+ file://op-cross-compile.patch;patch=1;pnum=0 \
file://acinclude.m4"
S = "${WORKDIR}/oprofile"
inherit autotools
-# NOTE: this disables the build of the kernel modules.
-# Should add the oprofile kernel modules, for those with 2.4
-# kernels, as a seperate .oe file.
EXTRA_OECONF = "--with-kernel-support \
--without-x \
--disable-werror "
@@ -26,18 +25,3 @@ do_configure () {
cp ${WORKDIR}/acinclude.m4 ${S}/
autotools_do_configure
}
-# Available config options
-# --enable-abi enable abi portability code (default is disabled)
-# --enable-pch enable precompiled header (default is disabled)
-# --enable-gcov enable option for gcov coverage testing (default is disabled)
-# --disable-werror disable -Werror flag (default is enabled for non-release)
-# --disable-optimization disable optimization flags (default is enabled)
-# --with-kernel-support Use 2.6 kernel (no kernel source tree required)
-# --with-linux=dir Path to Linux source tree
-# --with-module-dir=dir Path to module installation directory
-# --with-extra-includes=DIR add extra include paths
-# --with-extra-libs=DIR add extra library paths
-# --with-x use the X Window System
-# --with-qt-dir where the root of Qt is installed
-# --with-qt-includes where the Qt includes are.
-# --with-qt-libraries where the Qt library is installed.