summaryrefslogtreecommitdiff
path: root/meta/packages/prelink/prelink_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/prelink/prelink_git.bb')
-rw-r--r--meta/packages/prelink/prelink_git.bb50
1 files changed, 0 insertions, 50 deletions
diff --git a/meta/packages/prelink/prelink_git.bb b/meta/packages/prelink/prelink_git.bb
deleted file mode 100644
index 06078ed68..000000000
--- a/meta/packages/prelink/prelink_git.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-SECTION = "devel"
-# Need binutils for libiberty.a
-DEPENDS = "elfutils binutils"
-DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
-and executables, so that far fewer relocations need to be resolved at \
-runtime and thus programs come up faster."
-LICENSE = "GPLv2"
-PV = "1.0+git${SRCPV}"
-PR = "r0"
-
-SRC_URI = "git://git.pokylinux.org/prelink-cross.git;protocol=git \
- file://prelink.conf \
- file://prelink.cron.daily \
- file://prelink.default"
-
-TARGET_OS_ORIG := "${TARGET_OS}"
-OVERRIDES_append = ":${TARGET_OS_ORIG}"
-
-S = "${WORKDIR}/git/trunk"
-
-inherit autotools
-
-BBCLASSEXTEND = "native"
-
-EXTRA_OECONF = "--disable-selinux --with-pkgversion=${PV}-${PR} \
- --with-bugurl=http://bugzilla.pokylinux.org/"
-
-do_install_append () {
- install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
- install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
- install -m 0644 ${WORKDIR}/prelink.default ${D}${sysconfdir}/default/prelink
-}
-
-pkg_postinst_prelink() {
-#!/bin/sh
-
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-
-prelink -a
-}
-
-pkg_postrm_prelink() {
-#!/bin/sh
-
-prelink -au
-}
-