summaryrefslogtreecommitdiff
path: root/meta/packages/qemu/qemu_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/qemu/qemu_cvs.bb')
-rw-r--r--meta/packages/qemu/qemu_cvs.bb25
1 files changed, 8 insertions, 17 deletions
diff --git a/meta/packages/qemu/qemu_cvs.bb b/meta/packages/qemu/qemu_cvs.bb
index 137262ca2..4af21f4a8 100644
--- a/meta/packages/qemu/qemu_cvs.bb
+++ b/meta/packages/qemu/qemu_cvs.bb
@@ -1,7 +1,7 @@
LICENSE = "GPL"
DEPENDS = "zlib"
-PV = "0.9.0+cvs${SRCDATE}"
-PR = "r4"
+PV = "0.9.1+cvs${SRCDATE}"
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
FILESDIR = "${WORKDIR}"
@@ -9,13 +9,10 @@ FILESDIR = "${WORKDIR}"
SRC_URI = "\
cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
- file://03_machines_list_no_error.patch;patch=1;pnum=0 \
- file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
file://06_exit_segfault.patch;patch=1;pnum=0 \
file://10_signal_jobs.patch;patch=1;pnum=0 \
file://11_signal_sigaction.patch;patch=1;pnum=0 \
- file://12_signal_powerpc_support.patch;patch=1;pnum=1 \
file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
file://31_syscalls.patch;patch=1;pnum=0 \
file://32_syscall_sysctl.patch;patch=1;pnum=0 \
@@ -29,27 +26,21 @@ SRC_URI = "\
file://65_kfreebsd.patch;patch=1;pnum=0 \
file://66_tls_ld.patch;patch=1;pnum=0 \
file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
- file://93-oh-pl110-rgb.patch;patch=1;pnum=0 \
file://qemu-0.9.0-nptl.patch;patch=1 \
file://qemu-0.9.0-nptl-update.patch;patch=1 \
file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
file://workaround_bad_futex_headers.patch;patch=1 \
- file://fix_segfault.patch;patch=1"
-
-# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
-# file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
-# file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
-# file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
-# file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
-# file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
-# file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
-# file://debian/patches/96-x.patch;patch=1"
+ file://fix_segfault.patch;patch=1 \
+ file://no-strip.patch;patch=1"
S = "${WORKDIR}/qemu"
#EXTRA_OECONF += "--disable-sdl"
-#EXTRA_OECONF += "--target-list=arm-linux-user"
+#EXTRA_OECONF += "--target-list=arm-linux-user,arm-softmmu"
EXTRA_OECONF += "--disable-gfx-check"
inherit autotools
+do_configure() {
+ ${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
+}