summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/prelink/prelink_git.bb (renamed from meta/packages/prelink/prelink_20100106.bb)17
1 files changed, 11 insertions, 6 deletions
diff --git a/meta/packages/prelink/prelink_20100106.bb b/meta/packages/prelink/prelink_git.bb
index a84aaa267..06078ed68 100644
--- a/meta/packages/prelink/prelink_20100106.bb
+++ b/meta/packages/prelink/prelink_git.bb
@@ -1,12 +1,14 @@
SECTION = "devel"
-DEPENDS = "elfutils"
+# Need binutils for libiberty.a
+DEPENDS = "elfutils binutils"
DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
and executables, so that far fewer relocations need to be resolved at \
runtime and thus programs come up faster."
-LICENSE = "GPL"
+LICENSE = "GPLv2"
+PV = "1.0+git${SRCPV}"
PR = "r0"
-SRC_URI = "http://people.redhat.com/jakub/prelink/prelink-${PV}.tar.bz2 \
+SRC_URI = "git://git.pokylinux.org/prelink-cross.git;protocol=git \
file://prelink.conf \
file://prelink.cron.daily \
file://prelink.default"
@@ -14,12 +16,15 @@ SRC_URI = "http://people.redhat.com/jakub/prelink/prelink-${PV}.tar.bz2 \
TARGET_OS_ORIG := "${TARGET_OS}"
OVERRIDES_append = ":${TARGET_OS_ORIG}"
-S = "${WORKDIR}/prelink"
-
-EXTRA_OECONF = "--disable-64bit"
+S = "${WORKDIR}/git/trunk"
inherit autotools
+BBCLASSEXTEND = "native"
+
+EXTRA_OECONF = "--disable-selinux --with-pkgversion=${PV}-${PR} \
+ --with-bugurl=http://bugzilla.pokylinux.org/"
+
do_install_append () {
install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf