summaryrefslogtreecommitdiff
path: root/meta/recipes-support/gnutls/gnutls_2.12.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnutls/gnutls_2.12.16.bb')
-rw-r--r--meta/recipes-support/gnutls/gnutls_2.12.16.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-support/gnutls/gnutls_2.12.16.bb b/meta/recipes-support/gnutls/gnutls_2.12.16.bb
new file mode 100644
index 000000000..3c9b8096e
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls_2.12.16.bb
@@ -0,0 +1,19 @@
+require gnutls.inc
+
+PR = "${INC_PR}.5"
+
+SRC_URI += "file://gnutls-openssl.patch \
+ file://correct_rpl_gettimeofday_signature.patch \
+ file://configure-fix.patch \
+ "
+
+SRC_URI[md5sum] = "0414bba9760201f27d66787997cbadfb"
+SRC_URI[sha256sum] = "d04328857d9e420eca53f7f7fd615bc76d2f5d74984a9b90c0f2c5f7b5bf5b4a"
+
+python() {
+ if not ((d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1):
+ # if GPLv3 add patch
+ src_uri = (d.getVar("SRC_URI", False) or "").split()
+ src_uri.append("file://fix-gettext-version.patch")
+ d.setVar("SRC_URI", " ".join(src_uri))
+}