summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/jpeg/jpeg-native_6b.bb13
-rw-r--r--meta/packages/jpeg/jpeg_6b.bb14
2 files changed, 3 insertions, 24 deletions
diff --git a/meta/packages/jpeg/jpeg-native_6b.bb b/meta/packages/jpeg/jpeg-native_6b.bb
deleted file mode 100644
index 2591a7ab1..000000000
--- a/meta/packages/jpeg/jpeg-native_6b.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-SECTION = "libs"
-require jpeg_${PV}.bb
-inherit native
-DEPENDS = ""
-
-do_stage() {
- install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
- install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
- install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
- install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
- install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
- oe_libinstall -so libjpeg ${STAGING_LIBDIR}
-}
diff --git a/meta/packages/jpeg/jpeg_6b.bb b/meta/packages/jpeg/jpeg_6b.bb
index d64fb0996..ea05c6d34 100644
--- a/meta/packages/jpeg/jpeg_6b.bb
+++ b/meta/packages/jpeg/jpeg_6b.bb
@@ -4,8 +4,9 @@ SECTION = "libs"
PRIORITY = "required"
DEPENDS = "libtool-cross"
+DEPENDS_virtclass-native = "libtool-native"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
file://debian.patch;patch=1 \
@@ -25,15 +26,6 @@ do_configure_prepend () {
rm -f ${S}/ltmain.sh
}
-do_stage() {
- install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
- install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
- install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
- install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
- install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
- oe_libinstall -so libjpeg ${STAGING_LIBDIR}
-}
-
do_install() {
install -d ${D}${bindir} ${D}${includedir} \
${D}${mandir}/man1 ${D}${libdir}
@@ -43,4 +35,4 @@ do_install() {
PACKAGES =+ "jpeg-tools "
FILES_jpeg-tools = "${bindir}/*"
-
+BBCLASSEXTEND = "native"