summaryrefslogtreecommitdiff
path: root/openembedded/packages/gcc/gcc-4.0.2
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/gcc/gcc-4.0.2')
-rw-r--r--openembedded/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch24
-rw-r--r--openembedded/packages/gcc/gcc-4.0.2/arm-softfloat.patch16
-rw-r--r--openembedded/packages/gcc/gcc-4.0.2/ldflags.patch22
3 files changed, 62 insertions, 0 deletions
diff --git a/openembedded/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch b/openembedded/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch
new file mode 100644
index 000000000..c4897c033
--- /dev/null
+++ b/openembedded/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch
@@ -0,0 +1,24 @@
+# Dimitry Andric <dimitry@andric.com>, 2004-05-01
+#
+# * Removed the extra -lfloat option from LIBGCC_SPEC, since it isn't needed
+# anymore. (The required functions are now in libgcc.)
+#
+# Fixes errors like
+# arm-softfloat-linux-gnu/3.4.0/../../../../arm-softfloat-linux-gnu/bin/ld: cannot find -lfloat
+# collect2: ld returned 1 exit status
+# make[2]: *** [arm-softfloat-linux-gnu/gcc-3.4.0-glibc-2.3.2/build-glibc/iconvdata/ISO8859-1.so] Error 1
+# when building glibc-2.3.3 with gcc-3.4.0 for arm-softfloat
+
+Index: gcc-4.0.2/gcc/config/arm/linux-elf.h
+===================================================================
+--- gcc-4.0.2.orig/gcc/config/arm/linux-elf.h 2005-03-04 16:14:01.000000000 +0000
++++ gcc-4.0.2/gcc/config/arm/linux-elf.h 2005-11-11 18:02:54.000000000 +0000
+@@ -56,7 +56,7 @@
+ %{shared:-lc} \
+ %{!shared:%{profile:-lc_p}%{!profile:-lc}}"
+
+-#define LIBGCC_SPEC "%{msoft-float:-lfloat} %{mfloat-abi=soft*:-lfloat} -lgcc"
++#define LIBGCC_SPEC "-lgcc"
+
+ /* Provide a STARTFILE_SPEC appropriate for GNU/Linux. Here we add
+ the GNU/Linux magical crtbegin.o file (see crtstuff.c) which
diff --git a/openembedded/packages/gcc/gcc-4.0.2/arm-softfloat.patch b/openembedded/packages/gcc/gcc-4.0.2/arm-softfloat.patch
new file mode 100644
index 000000000..c86c83ed1
--- /dev/null
+++ b/openembedded/packages/gcc/gcc-4.0.2/arm-softfloat.patch
@@ -0,0 +1,16 @@
+Index: gcc-4.0.2/gcc/config/arm/t-linux
+===================================================================
+--- gcc-4.0.2.orig/gcc/config/arm/t-linux 2004-05-15 12:41:35.000000000 +0000
++++ gcc-4.0.2/gcc/config/arm/t-linux 2005-11-11 16:07:53.000000000 +0000
+@@ -4,7 +4,10 @@
+ LIBGCC2_DEBUG_CFLAGS = -g0
+
+ LIB1ASMSRC = arm/lib1funcs.asm
+-LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx
++LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx \
++ _negdf2 _addsubdf3 _muldivdf3 _cmpdf2 _unorddf2 _fixdfsi _fixunsdfsi \
++ _truncdfsf2 _negsf2 _addsubsf3 _muldivsf3 _cmpsf2 _unordsf2 \
++ _fixsfsi _fixunssfsi _floatdidf _floatdisf
+
+ # MULTILIB_OPTIONS = mhard-float/msoft-float
+ # MULTILIB_DIRNAMES = hard-float soft-float
diff --git a/openembedded/packages/gcc/gcc-4.0.2/ldflags.patch b/openembedded/packages/gcc/gcc-4.0.2/ldflags.patch
new file mode 100644
index 000000000..1196bf0c8
--- /dev/null
+++ b/openembedded/packages/gcc/gcc-4.0.2/ldflags.patch
@@ -0,0 +1,22 @@
+--- gcc-4.0.0/Makefile.tpl.old 2005-06-10 13:05:09.000000000 +0100
++++ gcc-4.0.0/Makefile.tpl 2005-06-10 13:05:10.000000000 +0100
+@@ -339,7 +339,7 @@
+ NM = @NM@
+
+ LD = @LD@
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+ RANLIB = @RANLIB@
+
+--- gcc-4.0.0/Makefile.in.old 2005-06-10 17:13:12.000000000 +0100
++++ gcc-4.0.0/Makefile.in 2005-06-10 17:13:22.000000000 +0100
+@@ -336,7 +336,7 @@
+ NM = @NM@
+
+ LD = @LD@
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+ RANLIB = @RANLIB@
+